Incorrect information in "Your tabs form last time" in about:home

VERIFIED FIXED

Status

Fennec Graveyard
General
--
minor
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: ahoza, Assigned: mfinkle)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0(X11;U;Linux armv7l; Nokia N900; en-US;rv:1.9.2.5pre) Gecko/20100519 Namoroka/3.6.5pre Fennec 1.1b2pre 

Information is not correct in "Your tabs form last time", if in the previous session, empty tabs were opened. 

Reproducible: Always

Steps to Reproduce:
1.Open Fennec.
2.Open 5 more tabs. (don't enter any information in Awesome bar)
3.In the last opened, enter google.com. (this should be the sixth tab)
4. Close Fennec and open it again.
  
Actual Results:  
"Your tabs form last time" contains the following text: "No tabs from last time"

Expected Results:  
"Your tabs form last time" should contain Google.
The current code in aboutHome.xhtml will only check the first 5 tabs from session restore. If those 5 tabs fail to meet the "show in list" criteria, the list would be empty.
For a FYI, what is the criteria?
No "about:" pages of any kind:

http://mxr.mozilla.org/mobile-browser/source/chrome/content/aboutHome.xhtml#165
(Assignee)

Updated

8 years ago
Whiteboard: mobile-triage
(Assignee)

Updated

8 years ago
Assignee: nobody → mark.finkle
(Assignee)

Updated

8 years ago
Whiteboard: mobile-triage
Created attachment 449274 [details] [diff] [review]
patch

This patch adds a counter so we can track the number of "valid" tabs we add to the startpage.
Attachment #449274 - Flags: review?(mbrubeck)
Comment on attachment 449274 [details] [diff] [review]
patch

r+ but I'm curious why we have such a small limit at all.  Won't it be pretty common for users to have more than 5 tabs open?
Attachment #449274 - Flags: review?(mbrubeck) → review+
(In reply to comment #5)
> (From update of attachment 449274 [details] [diff] [review])
> r+ but I'm curious why we have such a small limit at all.  Won't it be pretty
> common for users to have more than 5 tabs open?

It was arbitrary. Just didn't want to fill the screen and push down other content.

We could make it a preference (hidden) or show all. Madhava?
I'd show all, I think. A limit on # of add-ons makes sense, because the user didn't ask for or create them, but that's not the case for tabs. In fact, I wouldn't be surprised if the tab you want from last time is one of the last few, which would be excluded here.
Created attachment 449337 [details] [diff] [review]
patch 2

This patch shows all (no limit) pages from tab history, except about: pages
Attachment #449274 - Attachment is obsolete: true
Attachment #449337 - Flags: review?(mbrubeck)
Attachment #449337 - Flags: review?(mbrubeck) → review+
pushed to m-b:
http://hg.mozilla.org/mobile-browser/rev/00f83b41835b
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110922
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.