audit that try slaves sync up after reboots with the puppet server

RESOLVED FIXED

Status

Release Engineering
General
P3
normal
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: armenzg, Assigned: lsblakk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [buildslaves][puppet])

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
Created attachment 446557 [details]
log from first attempt of syncing up with puppet server

I made one of the try slaves that used to be in the sandbox network to sync up with puppet and there was a lot of output and an error in the log. Since they have been recloned they are up-to-date but we should ensure that they don't fall out of sync again.
(Reporter)

Comment 1

8 years ago
Created attachment 446558 [details]
log from second attempt at syncing up with puppet

Comment 2

8 years ago
Looks like yours?
Assignee: nobody → armenzg
(Reporter)

Comment 3

8 years ago
No, I can't take it now.
Assignee: armenzg → nobody

Updated

8 years ago
Priority: -- → P3
Hardware: x86 → All

Updated

8 years ago
Whiteboard: [buildslaves][puppet]

Updated

8 years ago
Assignee: nobody → bear

Comment 4

8 years ago
Manually created the buildbot-0.8.0pre directory and ensured the symlink and semaphore file are present.

I will be researching this further with bhearsum in the morning to find out why puppet is refusing to let buildbot play in the try-mac-slave* playground.

Applied to the following slaves:

try-mac-slave{02,03,04,06,07,08,09,10,11,12,13,14,16,17,18,19}
Looking into why Puppet isn't syncing them up.
Assignee: bear → bhearsum
Created attachment 447327 [details] [diff] [review]
fix case's in install package

Turns out that the case statements weren't using regex properly. Here's the more explicit way, fully tested.
Attachment #447327 - Flags: review?(bear)

Updated

8 years ago
Attachment #447327 - Flags: review?(bear) → review+
Comment on attachment 447327 [details] [diff] [review]
fix case's in install package

changeset:   159:05641475c4ab
Attachment #447327 - Flags: checked-in+
Mac problems should be fixed, back to lsblakk per bear.
Assignee: bhearsum → lsblakk
(Assignee)

Comment 9

8 years ago
Yup - confirmed that all mac try slaves are back online and coming back after reboots.  Thanks for everyone's part in getting this fixed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.