Flash video plays after tab is closed

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: nikhilr1984, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-05-30], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)

The flash in this page continues to play after closing the tab. This is the bug 531514. However, in my case it continues to play after I restart firefox. Furthermore, the playback is not consistent- it's cut off and sounds like something is getting overwritten into its buffer as it gets played. I had to disable the shockwave flash plugin to continue using firefox. It might be a good idea to create a separate process for flash plugin, so that it can be killed separately without closing firefox.

Reproducible: Couldn't Reproduce

Updated

9 years ago
Component: Extension Compatibility → General
QA Contact: extension.compatibility → general
Summary: http://www.wired.co.uk/videos/wired-things/2010-05/07/volvo-accidentally-smashes-new-s60-car → Flash video plays after tab is closed
Version: unspecified → 3.5 Branch

Comment 1

9 years ago
Is this an issue in Firefox's safe mode or a new profile as explained in https://support.mozilla.com/en-US/kb/Basic+troubleshooting ?

Firefox 3.6.4 will have separate processes for each plugin.
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Is this an issue in Firefox's safe mode or a new profile as explained in
> https://support.mozilla.com/en-US/kb/Basic+troubleshooting ?
> 
> Firefox 3.6.4 will have separate processes for each plugin.

Neither. I restarted firefox, but the sound (of the video) was still playing on from the previous session (little creepy), although there was no video being played anywhere. I guess it's just that the flash plugin was active. I had to disable flash plugin and enable it again to stop that sound. Thanks for the info on 3.6.4. That's just what I've been looking for.
Reporter, are you still seeing this issue with Firefox 4.0.1 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-05-30]
No reply, INCOMPLETE. Please retest with Firefox 4 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). Also, ensure you have the most up to date graphics drivers, operating system updates, and plugin versions (flash, java, etc). If you continue to see this issue with the newest Firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.