moulinex.com: Links for countries do not work

RESOLVED INVALID

Status

defect
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: michael.graubart7, Unassigned)

Tracking

Firefox Tracking Flags

(status1.9.1 ?)

Details

(Whiteboard: [trunk and comm-1.9.1], )

Attachments

(5 attachments)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.11pre) Gecko/20100515 SeaMonkey/2.0.6pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.11pre) Gecko/20100515 SeaMonkey/2.0.6pre

This page asks one to choose a country, but the links do not work. They do work in Safari.

Reproducible: Always

Steps to Reproduce:
1. Go to page as above.
2. Click on any country in the list.
3.
Actual Results:  
Nothing happens.

Expected Results:  
The website for the selected country should open.

Mac G4 (PPC), OS X 10.4.11.
Works for me on WinXP, Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.11pre) Gecko/20100513 Mnenhy/0.8.2 SeaMonkey/2.0.6pre, with many extensions installed. I doubt this is a Mac issue but of course I cannot be completely sure. Do you have any extensions installed? Can you reproduce the problem in Safe Mode?
The country links still do not work in Safe Mode. I should have said that the 'International' link does work, both in Safe Mode and normally.
(In reply to comment #2)
> The country links still do not work in Safe Mode. I should have said that the
> 'International' link does work, both in Safe Mode and normally.

Could you please try with a fresh new profile, too? This seems to be a JavaScript issue (the 'International' link is a normal one, all the others use JavaScript). Since it's the same for you in Safe Mode it cannot be an extension interfering so I guess it's a pref (which does not get deactivated in Safe Mode). If it works for you with a new profile all we have to do is identify the problematic pref in your normal profile.
You're getting warm! All the links work in a new profile.
(In reply to comment #4)
> You're getting warm! All the links work in a new profile.

Do you have JavaScript enabled at all in your normal profile? (Edit/Preferences/Advanced/Scripts & Plugins/Enable JavaScript for [x] Browser)

If it is enabled, please report the values for the following prefs (strings to be entered in the Filter text box on the page that appears if you enter "about:config" into the location bar and click through the warning):

dom.popup_allowed_events
dom.popup_maximum
privacy.popups.policy
Thanks for the detailed instructions; I wouldn't have known how to find all these things otherwise (but in my system, prefs is under SeaMonkey, not Edit).

JavaScript is enabled for the browser. (BTW, on that same page, should I enable plugins for Mail & Newsgroups or not?) 

dom.popup_allowed_events ... default/string/change click dblclick mouseup reset submit

dom.popup_maximum ... default/integer/20

privacy.popups.policy ... This does not exist. There are 8 other prefs. beginning with 'privacy.popups', but not this one. Do you want the values for any of these?
(In reply to comment #6)
> in my system, prefs is under SeaMonkey, not Edit

Well, I have no Mac. ;-)

> JavaScript is enabled for the browser

OK, so that's not it.

> on that same page, should I enable plugins for Mail & Newsgroups or not? 

Plugins are not related to this issue. Whether you enable plugins in MailNews or not is totally up to you; personally I have never found the need for that.

> There are 8 other prefs. beginning with 'privacy.popups', but not this one.
> Do you want the values for any of these?

Only if any of those are printed in bold (which means that they are different to the default values).

Do you have any pref starting with "capability.policy" set? Or something starting with "security"?
The 'privacy.popups' prefs in bold are:

privacy.popups.remove_blacklist...user set/boolean/false
privacy.popups.sound_enabled...user set/boolean/true
privacy.popups.sound–type...user set/integer/0

There is nothing beginning with 'capability.policy'.

As for 'security', there are 80 (eighty)! If I didn't miscount, that is. None of them is in bold.
PS: Here is a screenshot of the 'Privacy.popups' prefs.
Unfortunately all this doesn't help. I think I had something similar in the past, years ago, but of course I cannot remember which prefs were the problem back then.

Two things you could try:
a) open Tools/Web Development/Error Console and check whether any error message is added when clicking one of the problematic links (use the Clear button first if need be)
b) open about:config, sort by Status and go through all bold prefs (those have non-default values), ignoring all starting with "mail", "extensions", "ldap", "font" or "print". Look for anything suspecious. Yes, I know this is hard but I'm out of ideas.
Summary: Links for countries do not work → moulinex.com: Links for countries do not work
Thank you very much for taking all this trouble. As far as (b) is concerned, I don't know what to look for - i.e. what is suspicious and what isn't. But as far as (a) is concerned, this new error message appeared:

Error: xt_med is not defined
Source File: javascript:xt_med(xtpage,xtn2.replace('&s2=',''),'United%20Kingdom','S');javascript:void(window.open('http://www.moulinex.co.uk/'));
Line: 1

Does this help at all?
Please ignore the dark band across one part of the image. It is due to my accidentally having selected part of it before saving it as a JPEG.
(In reply to comment #12)
> this new error message appeared:
> 
> Error: xt_med is not defined
> Source File:
> javascript:xt_med(xtpage,xtn2.replace('&s2=',''),'United%20Kingdom','S');javascript:void(window.open('http://www.moulinex.co.uk/'));
> Line: 1
> 
> Does this help at all?

Yes, that's the reason why opening the link fails. The only question is what the actual cause is. The xt_med function should be available once the Home_fichiers/xtroi.js JavaScript file linked at the end of the source code of the page is loaded.

Can you load http://www.moulinex.com/Home_fichiers/xtroi.js (should display as text)? Furthermore, using Page Info from the context menu of the page should show "application/x-javascript" next to "Type".

Do you also see the error message in Safe Mode?

As for the prefs from your screen shot: None of them look related to me.
'Can you load http://www.moulinex.com/Home_fichiers/xtroi.js (should display as
text)?' - Yes, text is displayed.

'Furthermore, using Page Info from the context menu of the page should
show "application/x-javascript" next to "Type"' - Yes, it does.

'Do you also see the error message in Safe Mode?' - Yes, I do; same error message as before.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100510 SeaMonkey/2.1a1pre - Build ID: 20100510003927

Those javascript links don't work for me either. I'm attaching my prefs.js - the more eyes over a problem, the more chance to find the cause.
Setting platform to All (I'm on Linux) and confirming, see comment #16.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: PowerPC → All
status1.9.1: --- → ?
Whiteboard: [trunk and comm-1.9.1]
Version: unspecified → Trunk
P.S. In Konqueror, those Javascript links open a new tab whose contents vary according to whih "country" was selected. Also, "top" shows that it isn't Konqueror itself but something named "nspluginviewer" which is taking CPU time then (some country variants, at least, display an animation). Maybe the problem is not a preference but a plugin?
P.P.S. The "new tab" opened by Konqueror (comment #18) opens in the background, first as about:blank and then as something else. I need to open that tab to see its contents.
(In reply to comment #18)
> P.S. In Konqueror, those Javascript links open a new tab whose contents vary
> according to whih "country" was selected.

That is expected.

> Also, "top" shows that it isn't
> Konqueror itself but something named "nspluginviewer" which is taking CPU time
> then (some country variants, at least, display an animation). Maybe the problem
> is not a preference but a plugin?

If it is then not because of your findings. What you see is just the result of an active Flash plugin on the sites that open when you click any of the links (if it works, like for you with Konqueror or for me in any case).
Further to Comment #15, ''' 'Furthermore, using Page Info from the context menu of the page should show "application/x-javascript" next to "Type"' - Yes, it does''' applies to the text page that opens with http://www.moulinex.com/Home_fichiers/xtroi.js. But on re-reading Comment #14, I wonder whether the original www.moulinex.com home page was meant. On that page, Page Info shows 'text/html' against 'Type'.
(In reply to comment #16)
> Those javascript links don't work for me either. I'm attaching my prefs.js -
> the more eyes over a problem, the more chance to find the cause.

I cannot find anything there either, and: With that file copied to a fresh profile, I cannot reproduce the problem (however I had to cancel dozens of cookie requests since you set your home page to a group of dozens of sites that require cookies).

So it seems it's not a pref. Tony, does it also happen for you in Safe Mode?


(In reply to comment #21)
> I wonder whether the original www.moulinex.com home page was meant.

No, you got me right.
In reply to comment #22
> you set your home page to a group of dozens of sites that
require cookies
ah, sorry. You could have "doctored" that prefs.js to set the homepage to about: or about:blank, I don't think it would have made a difference.

> Tony, does it also happen for you in Safe Mode?
No, it doesn't, but clicking the link (I chose the French one this time) wants me to accept several third-party cookies for .xiti.com. I "denied" them all, but the Moulinex-France tab displayed OK (and in the foreground, unlike with Konqueror).

If it doesn't happen in SafeMode, it means it isn't a pref, is that it? I'll paste my about:support, wait a sec...
...and my about:plugins.
Maybe Michael can compare my extensions & plugins to what he has.
(In reply to comment #23)
> > Tony, does it also happen for you in Safe Mode?
> No, it doesn't

Well that's interesting, it does for Michael (he said).

> If it doesn't happen in SafeMode, it means it isn't a pref, is that it?

AFAIK: yes, Safe Mode only disables extensions (and maybe plugins, too) and uses default theme settings.

Tony: As for your extensions list, that's rather long. Could you try to identify the extension or plugin that breaks it for you (I know it's tedious but I think it's the best way to go forward)?
(In reply to comment #26)
> Tony: As for your extensions list, that's rather long. Could you try to
> identify the extension or plugin that breaks it for you (I know it's tedious
> but I think it's the best way to go forward)?

Best start with Adblock Plus and any other JavaScript-related extensions (well, implementation-wise most use JS but you know what I mean).
Yes, the bug happened in Safe Mode with my usual profile, but not with a new, clean profile (either in Safe Mode or ordinary mode).

The only extensions I have are Adblock Plus (but I tried disabling it and that made no difference) and spelling dictionaries in a few languages.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100510 Lightning/1.1a1pre SeaMonkey/2.1a1pre - Build ID: 20100510003927

With my usual profile and no change => l10n Moulinex links don't work.
Disable Adblock Plus, restart => they do.

I "denied" all 3rd-party cookies in both cases.
FWIW, I use the following ABP filters:
- Filter subscription: Liste FR
- Filter Subscription: EasyPrivacy + EasyList + EasyElement
- Custom exception rule:
@@|http://www.monarchie.be/assets/surrounds/popup_su19_h_en.html|$document
- Custom blocking rules:
|http://uea.org/kongresoj/stelo.swf
||google-analytics-com^

If anyone knows Wladimir Palant's BMO address-of-record, please add him to the CC list (trev -at- adblockplus -dot- org is unknown to Bugzilla).
In reply to a question on IRC

Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110601 Firefox/7.0a1 SeaMonkey/2.2a1pre ID:20110601003002

At http://www.moulinex.com/default.html I see on the right side a throbber, then a movie; on the left side a bunch of javascript links (which do nothing) and one HTTP link labeled "International" (which works). This is in my usual profile...
With the same version of SeaMonkey in an "almost new" profile, the JS links open a new page in a new tab.
This problem seems to involve the adblock-plus "EasyPrivacy" filter. Wladimir, you may want to move it out of SeaMonkey::General and into some more appropriate Product::Component.
Yes, EasyPrivacy blocks http://www.moulinex.com/js/xtroi.js which apparently this site cannot live without. That's something to report on http://forums.lanik.us/viewforum.php?f=64, not an Adblock Plus bug.
No longer blocks: abp
In view of comment #34 and #35 above, this is "not a Mozilla bug" and it has been reported to the responsible authority. => INVALID
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.