Port Bug 519099 [Location bar stops working and does not allow any input. Restarts does not help] to SeaMonkey

RESOLVED FIXED in seamonkey2.1a2

Status

SeaMonkey
Session Restore
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Misak Khachatryan, Assigned: Misak Khachatryan)

Tracking

Trunk
seamonkey2.1a2
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

v2
1.13 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

7 years ago
Created attachment 446963 [details] [diff] [review]
patch

From parent bug:

STEPS TO REPRODUCE
1. Make sure you have "Show my windows and tabs from last time" enabled
2. Go to http://www.chromeexperiments.com/detail/monster/
3. Click on "Launch Experiment"
4. Close the main window, leaving the popup as the only window open
5. Exit Firefox
6. Restart Firefox
7. It will not be possible to type anything in the Location bar

ADDITIONAL INFO
You wont be able to type anything into the Location bar now, restarting Firefox
wont help. Creating a new tab will not help either.

Only way to get out of this "locked" mode is to open a new window

Tested on Windows and could not reproduce, MAC OS X only?
Attachment #446963 - Flags: superreview?(neil)
Attachment #446963 - Flags: review?(neil)

Comment 1

7 years ago
Comment on attachment 446963 [details] [diff] [review]
patch

>       // make sure that at least the first window doesn't have anything hidden
>       if (this._initialState.windows[0])
>         delete this._initialState.windows[0].hidden;
>+      // Since nothing is hidden in the first window, it cannot be a popup
>+      delete this._initialState.windows[0].isPopup;
I don't know why the Firefox version of the file doesn't have the
if (this._initialState.windows[0])
check, but it makes no sense to have one line checked and one not checked.
(Assignee)

Comment 2

7 years ago
Created attachment 446966 [details] [diff] [review]
v2

I didn't found changeset, where it happen, lack of hg knowledge.
Attachment #446963 - Attachment is obsolete: true
Attachment #446966 - Flags: superreview?(neil)
Attachment #446966 - Flags: review?(neil)
Attachment #446963 - Flags: superreview?(neil)
Attachment #446963 - Flags: review?(neil)

Comment 3

7 years ago
Comment on attachment 446966 [details] [diff] [review]
v2

OK this version seems reasonable.
Attachment #446966 - Flags: superreview?(neil)
Attachment #446966 - Flags: superreview+
Attachment #446966 - Flags: review?(neil)
Attachment #446966 - Flags: review+
(Assignee)

Comment 4

7 years ago
Pushed: http://hg.mozilla.org/comm-central/rev/0ba4ad058461
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a2
You need to log in before you can comment on or make changes to this bug.