When closing a bug as a duplicate, the error "There is no field 'dup_id'" is displayed

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
Creating/Changing Bugs
--
critical
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: dkl, Assigned: dkl)

Tracking

({regression})

Bugzilla 4.0
regression
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 447100 [details] [diff] [review]
Patch to fix check_field_is_mandatory error (v1)

With the check in of a recent patch for bug 494395, the check_field_is_manatory function in set_global_validator() will cause a "There is no field '<field_name>'" error to be thrown if the field does not exist in the fielddefs table. The error can be reproduced by simply resolving a bug as a duplicate of another. The field 'dup_id' is not in the fielddefs table so the Bugzilla::Field->check('dup_id') fails. There may be other fields as well. I was able to resolve the error with the patch (attached). This could also be resolved by adding the 'dup_id' field to the fielddefs table which I am not sure why it is not there as people may want to search on bugs resolved as a duplicate of another bug.

Updated

8 years ago
Depends on: 494395
Keywords: regression
OS: Linux → All
Hardware: x86 → All
Target Milestone: --- → Bugzilla 3.8

Updated

8 years ago
Attachment #447100 - Attachment is patch: true
Attachment #447100 - Attachment mime type: application/octet-stream → text/plain
(Assignee)

Comment 1

8 years ago
Comment on attachment 447100 [details] [diff] [review]
Patch to fix check_field_is_mandatory error (v1)

requesting review from max since he committed this change.
Attachment #447100 - Flags: review?(mkanat)
(Assignee)

Comment 2

8 years ago
Comment on attachment 447100 [details] [diff] [review]
Patch to fix check_field_is_mandatory error (v1)

My fault, requesting review from timello.
Attachment #447100 - Flags: review?(mkanat) → review?(timello)

Comment 3

8 years ago
Comment on attachment 447100 [details] [diff] [review]
Patch to fix check_field_is_mandatory error (v1)

This fix looks OK to me, but since this is HEAD, would you possibly be interested in writing a patch to add dup_id to the fielddefs table?

Comment 4

8 years ago
Increasing severity to critical as this should block 3.7.1.
Severity: major → critical
Comment on attachment 447100 [details] [diff] [review]
Patch to fix check_field_is_mandatory error (v1)

Let me know if you can't write the patch then I'll write.
Attachment #447100 - Flags: review?(timello) → review+

Updated

8 years ago
Flags: approval?

Comment 6

8 years ago
Independently of the implementation of comment 3, this fix should be committed as it will prevent the same problem to occur with other "undefined" fields.

dkl, do you have bzr commit privs?
Assignee: create-and-change → dkl
Status: NEW → ASSIGNED
Flags: approval? → approval+
(Assignee)

Comment 7

8 years ago
(In reply to comment #6)
> Independently of the implementation of comment 3, this fix should be committed
> as it will prevent the same problem to occur with other "undefined" fields.
> 
> dkl, do you have bzr commit privs?

Yes, so I should just check in this generic fix and then file a new bug with patch to add the dup_id to the fielddefs?

Dave

Comment 8

8 years ago
(In reply to comment #7)
> Yes, so I should just check in this generic fix and then file a new bug with
> patch to add the dup_id to the fielddefs?

Yes, so that we can release 3.7.1 without "marking bugs as duplicate" being broken.
(Assignee)

Comment 9

8 years ago
Committing to: bzr+ssh://dkl%40redhat.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Bug.pm
Committed revision 7197.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.