Closed Bug 567950 Opened 10 years ago Closed 7 years ago

Intermittent browser_keyevents_during_autoscrolling.js | Timed out

Categories

(Toolkit :: XUL Widgets, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: philor, Assigned: froydnj)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274749799.1274752191.2411.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/05/24 18:09:59
s: talos-r3-leopard-045

TEST-PASS | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | maybe run tests <load:false, focus:true> -- loaded: interactive active window: ([object ChromeWindow @ 0x1498c300 (native @ 0x14a70ff4)]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window @ 0x17f0a5e0 (native @ 0x21371b04)]]) about:blank desired window: ([object XPCNativeWrapper [object Window @ 0x17f0a5e0 (native @ 0x21371b04)]]) about:blank child window: ([object XPCNativeWrapper [object Window @ 0x17f0a5e0 (native @ 0x21371b04)]]) about:blank docshell visible: true
++DOMWINDOW == 117 (0x189af414) [serial = 2278] [outer = 0x21371ad0]
WARNING: Unable to retrieve the tooltip node document.: file /builds/slave/mozilla-central-macosx-debug/build/layout/xul/base/src/nsXULTooltipListener.cpp, line 613
--DOMWINDOW == 116 (0x216fa0f4) [serial = 2226] [outer = 0x215bfb20] [url = http://example.com/tests/toolkit/components/places/tests/browser/399606-window.location.href.html]
(bunch more GC)
###!!! ASSERTION: bad hint in chrome code: 'hint != XOW && hint != SOW && hint != COW', file /builds/slave/mozilla-central-macosx-debug/build/js/src/xpconnect/src/xpcwrappednativescope.cpp, line 1043
(repeats three more times)
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
The first recorded time this showed up was after the tracemonkey merge: 23b20b0eb9f3. Rob, do you know if you saw anything like this on the tracemonkey tree before merging?
Who could tell? There were no instances of this in the last 168 hours in TM's 10.5.2 opt and debug mochitest-other, but then it's only been frequent in mozilla-central's 10.6.2 tests, and TM doesn't have 10.6.2 yet.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274847475.1274848557.1722.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/05/25 21:17:55

s: talos-r3-snow-016
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274847672.1274850017.7934.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/05/25 21:21:12

s: talos-r3-leopard-030
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275013568.1275016216.14508.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/05/27 19:26:08
s: talos-r3-leopard-043
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275074196.1275076517.10959.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/05/28 12:16:36
s: talos-r3-leopard-021
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275098416.1275099994.14418.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/05/28 19:00:16
s: talos-r3-snow-030
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275104200.1275105635.4191.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/05/28 20:36:40
s: talos-r3-snow-009
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275107321.1275108589.15542.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/05/28 21:28:41
s: talos-r3-snow-036
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275260442.1275262486.19241.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/05/30 16:00:42
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/06/05 00:53:29
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275724409.1275725343.10066.gz
I starred this (first, followed by philor and jesse) on tbpl, but the robot doesn't seem to have posted here:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276040673.1276044100.30829.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/06/08 16:44:33
s: talos-r3-leopard-036

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276145645.1276147898.27508.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/06/09 21:54:05

s: talos-r3-snow-017
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276147605.1276149478.1096.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/06/09 22:26:45

s: talos-r3-snow-014
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276144705.1276148536.29935.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/06/09 21:38:25

s: talos-r3-leopard-013
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276152618.1276154544.21967.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/06/09 23:50:18

s: talos-r3-leopard-024
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276172502.1276173736.31703.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/06/10 05:21:42

s: talos-r3-snow-016
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276227754.1276228670.21833.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/06/10 20:42:34

s: talos-r3-snow-007
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276228060.1276229728.25270.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/06/10 20:47:40

s: talos-r3-leopard-004
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276233168.1276234983.9728.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/06/10 22:12:48

s: talos-r3-leopard-019
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
I think that this bug isn't toolkit/XUL widgets. The all logs show the cause is in specific code of Mac.

> TEST-START | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js
> TEST-PASS | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | before wait for focus -- loaded: interactive active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object XPCNativeWrapper [object Window]]) about:blank child window: ([object XPCNativeWrapper [object Window]]) about:blank docshell visible: true
> TEST-PASS | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | must wait for load
> TEST-PASS | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | already focused
> TEST-PASS | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | maybe run tests <load:false, focus:true> -- loaded: interactive active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object XPCNativeWrapper [object Window]]) about:blank child window: ([object XPCNativeWrapper [object Window]]) about:blank docshell visible: true
> TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out
> TEST-INFO | checking window state
> TEST-PASS | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) data:text/html,<body%20style="height:10000px;"></body> desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XPCNativeWrapper [object Window]]) data:text/html,<body%20style="height:10000px;"></body> docshell visible: true
> TEST-PASS | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | already focused
> TEST-PASS | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) data:text/html,<body%20style="height:10000px;"></body> desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XPCNativeWrapper [object Window]]) data:text/html,<body%20style="height:10000px;"></body> docshell visible: true
> TEST-START | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_save_resend_postdata.js

And looks like onFocus() of the test isn't called.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276586325.1276588298.6764.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/06/15 00:18:45

s: talos-r3-snow-027
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_keyevents_during_autoscrolling.js | Timed out