Closed Bug 567973 Opened 10 years ago Closed 9 years ago

Search engine suggestions not always visible.

Categories

(Firefox :: Search, defect)

3.6 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 542990

People

(Reporter: kulmegil, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Probably not the most important of bugs and not noticeable by average user.
But I find it very annoying for a few reasons:

1) If user is unlucky it will reproduce at the last letter he typed

2) It's definitely more noticeable since I know about it :)

3) When using extensions (omnibar, foobar) witch merge search engine with "awesomebar" (urlbar) suggestions - it's a lot more annoying to see rich style list of urlbar suggestions "blinking" during typing.

Reproducible: Sometimes

Steps to Reproduce:
1. Select search engine that supports suggestions
2. Pick a long phrase and try "not to type to slow" :)
3. At some character You'll probably notice that search suggestions popup won't show but will reappear again after typing another.
Actual Results:  
Suggestions list may not appear at some (random) characters. 

Expected Results:  
Suggestions list should be visible all the time when typing.
(unless user misspell phrase)
Occurs for me sporadically too - is extremely irritating.

On apparently random letters out of the phrase being typed, the search suggestion does not appear. This is most noticeable when this occurs on the very last letter, since you stop typing, expecting to see the suggestion list, but instead have to type a few extra characters/remove a few to make it appear.

Win7 x64; Fx 3.6.4b5 - but has occurred since at least early 3.6.x versions (if not 3.5 or before, but less sure).
Has been working fine for several months now. (At least in Firefox 4)

Just tested typing really slowly several phrases with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101217 Firefox/4.0b9pre ID:20101217030324
...and worked perfectly.

Have you seen this recently, or can it be marked as "worksforme"?
Component: General → Search
QA Contact: general → search
Version: unspecified → 3.6 Branch
Bug 542990 matches my original symptoms and also comment 0, duping. 
Note: Haven't experienced this recently (using trunk).
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542990
You need to log in before you can comment on or make changes to this bug.