Closed Bug 568 Opened 22 years ago Closed 19 years ago

NGLayout Crashes on this URL trying parse cookie date

Categories

(Core :: DOM: HTML Parser, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: angus, Assigned: scullin)

References

()

Details

(Keywords: crash)

Crashes every time...

Here's a stack trace:
MSVCRTD! 102406c4()
NET_ParseDate(char * 0x01036c5b) line 577 + 20 bytes
NET_SetCookieStringFromHttp(int 102, URL_Struct_ * 0x010c1a90, MWContext_ *
0x010c1d60, char * 0x010c1cc0, char * 0x01036c2c) line 2416 + 14 bytes
NET_ParseMimeHeader(int 102, MWContext_ * 0x010c1d60, URL_Struct_ * 0x010c1a90,
char * 0x01036c20, char * 0x01036c2c, int 1) line 1617 + 28 bytes
net_parse_http_mime_headers(_ActiveEntry * 0x010c1ef0) line 1982 + 35 bytes
net_ProcessHTTP(_ActiveEntry * 0x010c1ef0) line 3506 + 9 bytes
NET_ProcessNet(PRFileDesc * 0x010c1380, int 2) line 3266 + 13 bytes
NET_PollSockets() line 180 + 18 bytes
nsNativeViewerApp::Run() line 68
main(int 1, char * * 0x00fe4af0) line 109
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1b304()
Component: Unknown → Parser
Adding crash keyword
Keywords: crash
Status: RESOLVED → VERIFIED
Verified fixed.
mid-air collision ? / bugzilla cleanup
Reopening (current State: verified and no resolution)
Status: VERIFIED → REOPENED
fixed
Status: REOPENED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
verfy
Status: RESOLVED → VERIFIED
Duplicate of this bug: 902860
You need to log in before you can comment on or make changes to this bug.