Closed Bug 568218 Opened 12 years ago Closed 10 years ago

Firefox incorrectly honors mimeinfo.cache on Linux and ignores defaults.list and mimeapps.list

Categories

(Firefox :: General, defect)

3.6 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 727422

People

(Reporter: gustavo, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100415 Caixa Magica/1.9.2.3-0.1xcm14 (14) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100415 Caixa Magica/1.9.2.3-0.1xcm14 (14) Firefox/3.6.3

Firefox is handling file associations in a broken way on Linux

- it ignores defaults.list and mimeapps.list
- it honors mimeinfo.cache which is a cache file not file association list 

(changes on this file are undone by the system each time a new application is installed - this happens via the command "update-desktop-database")

Note: defaults.list and mimeapps.list are part of the shared-mime-info package from freedesktop.org and are usually located on /usr/share/applications


Reproducible: Always

Steps to Reproduce:
1.go to a directory that hosts files via http
2.click on a file
3.check that the handler for that mimetype depends on what is present in mimeinfo.cache and doesn't depend on defaults.list and mimeapps.list
Actual Results:  
Firefox opens the first application listed on mimeinfo.cache for the corresponding mimetype.

Expected Results:  
Firefox should open the first application listed on mimeapps.list for the corresponding mimetype or if it is not listed the default application for that mimetype listed on defaults.list
I forgot to add that apparently mimeinfo.cache lists the handlers in an arbitrary order which is not controlled by the user.
Version: unspecified → 3.6 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 727422
You need to log in before you can comment on or make changes to this bug.