App runs much slower under profiler than without profiler

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: mike, Assigned: rulohani)

Tracking

unspecified
Q3 11 - Serrano
Bug Flags:
flashplayer-qrb +

Details

(Whiteboard: Profiler_bugs)

Attachments

(1 attachment)

865.12 KB, application/zip
Details
(Reporter)

Description

9 years ago
Created attachment 447786 [details]
Repro sample

Steps to reproduce:
1. Download and unzip soap.zip, which contains the source and binary for a simple Flex program.
2. In Flash Builder, make a project called "WSTest"
3. Copy the downloaded MXML, WSDL, and XML files into the WSTest project's "src" directory
4. Compile and run
5. Click the "Call WebService" button in the app; then move the mouse pointer so it is no longer hovering over the button, so that you'll be able to tell when it is done.  On my machine, it takes about 24 seconds to complete.
6. Exit the app, and run it again, but this time, with the profiler active.  Do a performance profile (not memory profile).
7. Again, click "Call WebService" in the app.

Actual result:
"Call WebService" button takes about 19 minutes to complete on my machine, compared to just 24 seconds when there is no profiler.

Expected result:
The profiler shouldn't cause that big of a slowdown in performance of the app.  A slight slowdown is acceptable, maybe 20% or so, or maybe 100% at worst, but this big a slowdown is too big.
(Reporter)

Updated

9 years ago
Blocks: 555460

Updated

9 years ago
Component: Virtual Machine → Profiler

Updated

9 years ago
Assignee: nobody → rulohani
Status: NEW → ASSIGNED
Flags: flashplayer-qrb+
Priority: -- → P3
Whiteboard: Profiler_bugs
Target Milestone: --- → flash10.2
(Assignee)

Comment 1

9 years ago
With the attached sample app I get the following results on my machine (MacBook Pro 10.5.8 2.8GHz Intel core 2 Duo, 4GB RAM):

With the flash player build (10.0.45.2) which is default right now in the Flash Builder 4:
App completion time ( time in which the spinning wheel disappears): 
Without profiler: 23 sec
With Perf profiling: 26sec (approx). 

With the flash player build (10.1.53.64):
App completion time ( time in which the spinning wheel disappears): 
Without profiler: 23 sec
With Perf profiling: 26 sec (approx). 

I am seeing the behavior as mentioned by Mike Morearty above.

Comment 2

9 years ago
Ruchi, to confirm -- are you also seeing the 19 minute for the profiled app to complete the web service call  (vs. 24 sec when not using the profiler)?
(Assignee)

Comment 3

9 years ago
Dan, I am not seeing the 19 minutes delay for the profiled app completion. With profiling I see around 26 sec approx for the app to complete which is pretty much same as without profiling (23-24 sec). I would like to see if anyone else is seeing the delay with the profiling. I will request some QE internally to see if this is reproducible.
(Assignee)

Comment 4

9 years ago
One of the flash player QE verified internally and was unable to reproduce the delayed behavior as mentioned in the bug. The time taken for the app to complete with profiler is slightly more (~3-4 sec) than the time while running normally. Should this be closed ?
(Assignee)

Comment 5

9 years ago
(In reply to comment #1)
> 
> I am seeing the behavior as mentioned by Mike Morearty above.

Just noticed the missing "not" in my earlier comment above! No mistakes this time - "unable to repro".

Comment 6

9 years ago
Thanks for the confirmation.  Marking as Resolved/WORKSFORME
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.