Remove "browser.history_expire_days" usage from the tree

RESOLVED FIXED in mozilla31

Status

RESOLVED FIXED
9 years ago
4 months ago

People

(Reporter: dougt, Assigned: jefry.reyes)

Tracking

unspecified
mozilla31

Firefox Tracking Flags

(e10s-)

Details

(Whiteboard: [good first bug][mentor=mak][lang=cpp][lang=js])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
I am not sure how significant this is...

In e10s, child processes do not have the ability to clear preferences (read only).  When global history is started, it reads in preferences.  It also tries to clear "browser.history_expire_days".

It isn't obvious to me if we should be clearing this preferences in the chrome process, or simply not starting up global history, or simply ignoring the error.

Thoughts?

Comment 1

9 years ago
Shouldn't this whole thing be remoted? (Or even not exist in content?)
Er, why is this even running in the content process?  The chrome process should be setting it as appropriate, however.
(Reporter)

Comment 3

9 years ago
The code path might have been caused by 568612, but anytime that nav history is created, we will have problems.

Can we just disable global history in content (maybe stop it from being registered)
Assignee: nobody → josh
Duplicate of this bug: 603470
Assignee: josh → nobody
tracking-e10s: --- → +
qawanted to retest
tracking-e10s: + → ?
Keywords: qawanted
this bug doesn't make sense today on desktop, since browser.history_expire_days doesn't exist anymore. Is this for a related setting on mobile or just outdated?
and fwiw we should remove these lines if mobile doesn't make use of it
http://mxr.mozilla.org/mozilla-central/search?string=history_expire_days
Not important for e10s then. NI'ing finkle to see if we can clear that code in mobile
tracking-e10s: ? → -
Flags: needinfo?(mark.finkle)
Yeah, we can remove those lines from mobile.js
Flags: needinfo?(mark.finkle)
morphing the bug to cover removing the outdated code, making it a mentored bug.
Keywords: qawanted
Summary: [e10s] "browser.history_expire_days" clear user pref doesn't work in child processes → Remove "browser.history_expire_days" usage from the tree
Whiteboard: [good first bug][mentor=mak][lang=cpp][lang=js]
(Assignee)

Updated

5 years ago
Assignee: nobody → jefry.reyes
(Assignee)

Comment 11

5 years ago
Created attachment 8411839 [details] [diff] [review]
Removes outdated code from tree.
Attachment #8411839 - Flags: review?(mak77)
Comment on attachment 8411839 [details] [diff] [review]
Removes outdated code from tree.

Review of attachment 8411839 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #8411839 - Flags: review?(mak77) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed

Updated

5 years ago
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/4dc6cd04f8ff
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31

Updated

4 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.