"view-source:" URLs handle mime type

RESOLVED DUPLICATE of bug 77337

Status

defect
P3
minor
RESOLVED DUPLICATE of bug 77337
19 years ago
3 years ago

People

(Reporter: dolmen, Assigned: law)

Tracking

Trunk
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

19 years ago
The "view-source:" URL usually used to view the source of HTML pages can not be
used to view files which have a mime type not assigned to Mozilla.

Example:
view-source:http://www.netscape.com/h.js

This show the "Dowloading" dialog box: "This file has mime type
application/x-javascript and cannot be viewed using Mozilla. You can open it
with another application, or save it to disk.". "Open using..."/"Save to disk"

The view-source: URLs are sometimes used by web sites authors to show source
code in a separate window without requiring server-side processing to transform
the code in HTML.




Suggestion of correction:
any file should be viewable as source in the "View source" box, whatever the
mime type is.

Suggestion of future improvement:
the mime type could still be used to select the best source viewer. For example:
colored HTML for text/html, colored XML for text/*-xml, text for text/*
hex viewer for else

Comment 1

19 years ago
over to Networking.
Assignee: asa → gagan
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
QA Contact: doronr → tever

Comment 2

19 years ago
->me
Assignee: gagan → darin
Component: Networking → Networking: HTTP

Updated

19 years ago
Blocks: 61688

Comment 3

19 years ago
dup of 15372 ?  seems to carry a bit of extraneous info as well as good
suggestions.  perhaps 15372 is a dup of this?

Comment 4

19 years ago

*** This bug has been marked as a duplicate of 15372 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
->
Really belongs in file handling.
HTTP is for problems w/ http: urls, not view-source: urls :)
Status: RESOLVED → REOPENED
Component: Networking: HTTP → File Handling
Resolution: DUPLICATE → ---

Comment 6

17 years ago
The dupe is in Parser, but that happened before this component was created.
Assignee: darin → law
Status: REOPENED → NEW
QA Contact: tever → sairuh
QA Contact: sairuh → petersen
fixed long since.

*** This bug has been marked as a duplicate of 77337 ***
Status: NEW → RESOLVED
Closed: 19 years ago17 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.