Reftest log should show which assertions fired when the number of assertions is unexpected

VERIFIED WORKSFORME

Status

Testing
Reftest
VERIFIED WORKSFORME
8 years ago
8 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
(Can't decide whether I should mark the severity as enhancement or blocker, so I'm leaving it at normal.)

Steps to reproduce:
 1) Send attachment 448353 [details] [diff] [review] to the tryserver.
 2) Watch content/svg/content/src/crashtests/535691-1.svg go orange due to asserting twice when it's not supposed to assert.

Actual results:
The log doesn't say which assertions fired. Neither short http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1275151853.1275161167.17648.gz#err5 nor long http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1275151853.1275161167.17648.gz&fulltext=1#err5

Expected results:
Expected the logs to say which assertions fired.
Works for me.  You just have to look at the full log and scroll up a little, since the assertion has already happened by the time the message is logged.  Each assertion comes with a stack (although the stacks are currently broken) so there's a bit of vertical space you have to scroll through.

In this case, it was two occurrences of:

###!!! ASSERTION: unknown nsISVGValue: 'Not Reached', file /builds/slave/tryserver-linux-debug/build/content/svg/content/src/nsSVGElement.cpp, line 1010
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

8 years ago
Oops. Right. Verifying.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.