bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

javascript: url starts throbber and stop button and progress bar

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P3
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: andrew, Assigned: Paul Chen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001010
BuildID:    2000091312

A javascript: URL will cause the throbber and stop button and progress bar to
flash momentarily, even if the javascript is not actually causing a change in
location.

Reproducible: Always
Steps to Reproduce:
Click on a javascript: link that goes nowhere.

Actual Results:  Stop button, throbber, and progress bar all 'activate' momentarily.

Expected Results:  Stop button, throbber, and progress bar should only activate
if the javascript that is run actually causes the browser to go to a new location.
(Reporter)

Comment 1

18 years ago
Created attachment 17311 [details]
Page that demonstrates the bug

Comment 2

18 years ago
Using 102409-MN6, I could reproduce this bug.  I tried the same procedure with a
onMouseOver and everything was normal.  Not sure if this is really a bug since
you are technically clicking on a link.

Comment 3

18 years ago
Confirming using WinNT trunk and branch binaries 2000102604, 2000102609.
Also on Linux trunk and branch binaries 2000102608, 2000102609.


But browser issue, not engine. Reassigning to Networking for further triage -
Assignee: rogerl → gagan
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Networking
Ever confirmed: true
QA Contact: pschwartau → tever

Comment 4

18 years ago
I don't see how this is a networking bug.  An HTTP channel should not even be
created in this case.  Over to docshell for further triaging.
Component: Networking → Embedding: Docshell

Comment 5

18 years ago
seems like darin's attempt didn't get it to docshell... 
Assignee: gagan → adamlock
QA Contact: tever → adamlock

Comment 6

18 years ago
Some javascript: URL could conceivably be a lengthy operation involving loading 
content so I don't see that the throbber shouldn't be turned on just because of 
the schema. Perhaps it would be better for the throbber to pause for a 
moment before "throbbing" to allow quick loads and things like this to happen 
without briefly enabling it?

Reassigning to XP apps
Component: Embedding: Docshell → XP Apps

Comment 7

18 years ago
Really reassigning this time
Assignee: adamlock → pchen
QA Contact: adamlock → sairuh

Comment 8

17 years ago
This is particularly silly with a javascript url like <a
href="javascript:void(0)">. I'd think that only JavaScript that is changing the
page location should activate the throbber. A delayed throbber might be a
reasonable compromise for slow javascript.

Changing to OS All because of Linux comments by Phil Schwartau.
OS: Windows 98 → All

Comment 9

17 years ago
Test case no longer demnstrates the "problem", marking worksforme
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.