Closed Bug 569350 Opened 11 years ago Closed 11 years ago

support Variation Selector sequences on all platforms

Categories

(Core :: Graphics, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jfkthame, Unassigned)

References

Details

Attachments

(1 file)

Bug 552460 implemented support for Unicode variation sequences on Windows. However, support is not uniform across the other platforms:

- on OS X 10.5, variation sequences are apparently not supported;

- on OS X 10.6, the proper glyph substitution occurs but the glyph position appears to be incorrect (possible Core Text issue?) -- see bug 552460 comments 33 and 34;

- untested on Linux as yet.

We should ensure that we support these sequences across all platforms.
Now that the harfbuzz back-end is enabled, we have variation selector support on OS X and can enable the reftest from bug 552460 on this platform as well.

Not yet implemented on Linux.
Attachment #460520 - Flags: review?(jdaggett)
Comment on attachment 460520 [details] [diff] [review]
enable the variation selector reftest on OS X

I think the 'skip-if' should be 'random-if' instead, dbaron has in the past recommended that 'skip-if' only be used for cases where the testcase in question is known to cause a crash or some other form of trouble.  Including tests whose result is ignored still helps code coverage on all platforms.
Attachment #460520 - Flags: review?(jdaggett) → review+
(In reply to comment #2)
> I think the 'skip-if' should be 'random-if' instead

Good point; changed this.

Pushed http://hg.mozilla.org/mozilla-central/rev/beab39d49de9

Not closing this bug as we don't have VS support on Linux yet.
Depends on: 569770
Supported on Linux since bug 569770.

Marked test as passing:
http://hg.mozilla.org/mozilla-central/rev/cae10c2b6981
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Duplicate of this bug: 392588
You need to log in before you can comment on or make changes to this bug.