Closed Bug 569490 Opened 9 years ago Closed 9 years ago

Build should disable D3D9 layer if d3d9.h not found

Categories

(Core :: Widget: Win32, defect, trivial)

x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED FIXED

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(1 file)

Steps to reproduce problem:
1. Don't install an SDK that includes d3d9.h
2. Try to build
Expected result: OpenGL layer builds
Attached patch Possible patchSplinter Review
Compiles with and without d3d9.h
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #448637 - Flags: review?(ted.mielczarek)
Attachment #448637 - Flags: review?(jmuizelaar)
Comment on attachment 448637 [details] [diff] [review]
Possible patch

This seems fine. Do we know what SDK version the header appeared in? Because if we could pin that down we could instead use NTDDI_VERSION checks.
Attachment #448637 - Flags: review?(ted.mielczarek) → review+
Attachment #448637 - Flags: review?(jmuizelaar) → review+
Pushed changeset 7ebd45a02360 to mozilla-central.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
So the patch here has issues. With this patch if preferogl is true, and ogl creation fails, you won't get a D3D9 layer manager, this is undesirable behaviour.
You need to log in before you can comment on or make changes to this bug.