Closed Bug 569588 Opened 12 years ago Closed 12 years ago

Crash when making undo (Ctrl+Z) just after imap message delete [@ nsCOMPtr<nsIContent>::nsCOMPtr<nsIContent>(nsCOMPtr<nsIContent> const&) | nsImapOfflineSync::ProcessNextOperation()]

Categories

(MailNews Core :: Networking: IMAP, defect)

1.9.2 Branch
x86
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: matafagafo, Unassigned)

Details

(Keywords: crash, Whiteboard: fixed by Bug 519761)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100527 Firefox/3.6.4 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100526 Thunderbird/3.1

If you try to recover a deleted message in a IMAP account just after the delete command (quicly delete the press ctrl+Z) TB 3.1 Crash

Crash ID: f2e0c418-4a71-4dde-9c05-33cfc2100602
Crash Signature :
nsCOMPtr<nsIContent>::nsCOMPtr<nsIContent>(nsCOMPtr<nsIContent>  const&) | nsImapOfflineSync::ProcessNextOperation()

Reproducible: Always

Steps to Reproduce:
1.delete imap message 
2.press Ctrl+Z 
3.Crash
Actual Results:  
Crash

Expected Results:  
Recover deleted message.

TB 3.1 rc1 accessing remote imap (Gmail)
I just tried with 3.1 rc2, and the problem persist.
Fernando, if this one is also you, then you may be the only person crashing
 bp-9eea1c15-8436-4920-8da5-078cd2100602 from 2010-06-02 (no email address)

(there's only 3 crashes total in the last month)


f2e0c418-4a71-4dde-9c05-33cfc2100602 Doing 2 undo (ctrl-z) after delete 2 imap messages
0	thunderbird.exe	nsCOMPtr<nsIContent>::nsCOMPtr<nsIContent>	 objdir-tb/mozilla/dist/include/nsCOMPtr.h:545
1	thunderbird.exe	nsImapOfflineSync::ProcessNextOperation	mailnews/imap/src/nsImapOfflineSync.cpp:1074
2	thunderbird.exe	nsImapOfflineSync::ProcessNextOperation	mailnews/imap/src/nsImapOfflineSync.cpp:973
3	thunderbird.exe	nsImapOfflineSync::ProcessNextOperation	mailnews/imap/src/nsImapOfflineSync.cpp:973
4	thunderbird.exe	nsImapOfflineSync::ProcessNextOperation	mailnews/imap/src/nsImapOfflineSync.cpp:973
5	thunderbird.exe	nsImapOfflineSync::ProcessNextOperation	mailnews/imap/src/nsImapOfflineSync.cpp:973
6	thunderbird.exe	nsImapOfflineSync::ProcessNextOperation	mailnews/imap/src/nsImapOfflineSync.cpp:973
7	thunderbird.exe	nsImapOfflineSync::ProcessNextOperation	mailnews/imap/src/nsImapOfflineSync.cpp:973
8	thunderbird.exe	nsImapOfflineSync::ProcessNextOperation	mailnews/imap/src/nsImapOfflineSync.cpp:973
9	thunderbird.exe	nsImapMailFolder::PlaybackTimerCallback	mailnews/imap/src/nsImapMailFolder.cpp:9128
10	xpcom_core.dll	nsTimerImpl::Fire	xpcom/threads/nsTimerImpl.cpp:427
11	xpcom_core.dll	nsTimerEvent::Run	xpcom/threads/nsTimerImpl.cpp:519
12	xpcom_core.dll	nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:527 


xref Bug 536878 - crash [@ nsCOMPtr<nsIMsgDatabase>::nsCOMPtr<nsIMsgDatabase>(nsCOMPtr<nsIMsgDatabase> const&) | nsImapOfflineSync::ProcessNextOperation()] and [@ @0x0 | nsImapOfflineSync::ProcessNextOperation()] and [@ nsImapOfflineSync::ProcessNextOperation()]
Component: General → Networking: IMAP
Keywords: crash
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Summary: Crash when making undo (Ctrl+Z) just after imap message delete → Crash when making undo (Ctrl+Z) just after imap message delete [@ nsCOMPtr<nsIContent>::nsCOMPtr<nsIContent>(nsCOMPtr<nsIContent> const&) | nsImapOfflineSync::ProcessNextOperation()]
Version: unspecified → 1.9.2 Branch
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #2)
> (there's only 3 crashes total in the last month)
> 

Strange, to me, it's very easy to reproduce it.
In the course of testing another bug (bug 571800), I reproduced this crash, and tested it with versions all the way back to Thunderbird 3.0.2. I can reliably reproduce it in that version and all subsequent ones up to and including 3.1rc2.

I don't know where to look for the 3.0 alphas and betas, so I did not test those.

Scenario is:

1. Delete a message
2. QUICKLY undo the delete (^Z).

Since it may have to do with my particular IMAP server, I will offer a test account if you wish one. The IMAP service is that provided by Rackspace, at secure.emailsrvr.com.
Still crashing as of http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2010-08-14-00-comm-1.9.2/thunderbird-3.1.3pre.en-US.win32.installer.exe. Bug 519761 speculated to be related. But patch for that bug is supposed to be in the build above, and still crashes.
No, that's a 3.1.3 build; you need to be checking a trunk build - http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central-trunk/
(In reply to comment #7)
> Still crashing as of
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2010-08-14-00-comm-1.9.2/thunderbird-3.1.3pre.en-US.win32.installer.exe.
> Bug 519761 speculated to be related. But patch for that bug is supposed to be
> in the build above, and still crashes.

Oops, sorry, using wrong build - thought the patch was already in 3.1.3. I CANNOT reproduce this bug on http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central-trunk/thunderbird-3.2a1pre.en-US.win32.installer.exe as of today. So seems like the bug 519761 patch fixes this too.
Fernando, is this also gone for you with http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central-trunk/ ?  Or you can wait for it to be fixed 3.1.3pre probably tuesday or wednesday.
(In reply to comment #9)
> Fernando, is this also gone for you with
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central-trunk/
> ?  Or you can wait for it to be fixed 3.1.3pre probably tuesday or wednesday.

I just tried the  2010-08-20-00-comm-1.9.2/thunderbird-3.1.3pre.en-US.win32.installer.exe and the problem is solved in this build.
Thanks Fernando
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: fixed by Bug 519761
Crash Signature: [@ nsCOMPtr<nsIContent>::nsCOMPtr<nsIContent>(nsCOMPtr<nsIContent> const&) | nsImapOfflineSync::ProcessNextOperation()]
You need to log in before you can comment on or make changes to this bug.