New Tabs created via links should inherit history of the "ancestor" tab

RESOLVED DUPLICATE of bug 18808

Status

Firefox for Android Graveyard
General
--
enhancement
RESOLVED DUPLICATE of bug 18808
8 years ago
7 years ago

People

(Reporter: Jan D, Unassigned)

Tracking

(Depends on: 1 bug)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.3a5pre) Gecko/20100514 Namoroka/3.7a.5pre

When a new tab is opened by long-tap on a link and "open link in new tab", this new tab/page should inherit the history of the "ancestor" page instead of starting with a "blank" history. (ancestor page = the page from which the new tab has been opened).  
This would be totally unobtrusive; no UI elements would need to be added.
There are firefox add-ons for this function: tab history (outdated) and tabberwoky (https://addons.mozilla.org/en-US/firefox/addon/14439/) 


Reproducible: Always

Steps to Reproduce:
1.Follow a few links
2.open a link in a new tab via context-menu

Actual Results:  
The page in the new tab has a blank history

Expected Results:  
the history of the "ancestor" page should be inherited.

Updated

7 years ago
Depends on: 18808

Updated

7 years ago
OS: Windows XP → All
Hardware: x86 → All

Comment 1

7 years ago
dupe of bug 18808?

Updated

7 years ago
Duplicate of this bug: 573266
(In reply to comment #1)
> dupe of bug 18808?

yep.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 18808
You need to log in before you can comment on or make changes to this bug.