Firefox 3.7aX crash [@ GraphWalker<scanVisitor>::DoWalk(nsDeque&) ]

VERIFIED DUPLICATE of bug 500105

Status

()

defect
VERIFIED DUPLICATE of bug 500105
9 years ago
3 years ago

People

(Reporter: chofmann, Unassigned)

Tracking

({crash, regression})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
there is a crash on the trunk looks like

http://crash-stats.mozilla.com/report/index/3da9a84f-9436-469d-9b5e-094552100602

Frame  	Module  	Signature [Expand]  	Source
0 	xul.dll 	GraphWalker<scanVisitor>::DoWalk

http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=contains&query=GraphWalker%3CscanVisitor%3E%3A%3ADoWalk&date=06%2F02%2F2010%2013%3A10%3A24&range_value=1&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&signature=GraphWalker%3CscanVisitor%3E%3A%3ADoWalk%28nsDeque%26%29

not much on the stack but maybe some where around..
http://mxr.mozilla.org/mozilla-central/source/xpcom/base/nsCycleCollector.cpp#1782


looks like it first might have started to appear during the week of 2010 01 16 in builds from  the 14th or 15th.

checking --- GraphWalker.scanVisitor.::DoWalk 20100601-crashdata.csv
found in: 3.7a5pre 3.7a4
release total-crashes
              GraphWalker.scanVisitor.::DoWalk crashes
                         pct.
all     378282  15      3.9653e-05
3.7a5pre        1748    9       0.00514874
3.7a4   702     6       0.00854701

os breakdown
GraphWalker.scanVisitor.::DoWalkTotal 15
Win5.1  0.53
Win6.0  0.00
Win6.1  0.40
Mac10.4 0.00
Mac10.5 0.00
Mac10.6 0.00
Lin2.4  0.07

not correlated to startup.

Correlation to startup or time of session
15 total crashes for GraphWalker.scanVisitor.::DoWalk on 20100601-crashdata.csv
1 start up crashes inside 30 seconds of startup
2 start up crashes inside 3 minutes of startup

some test urls look like

   2 http://www.facebook.com/common/blank.html
   1 wyciwyg://10/http://wg226.odnoklassniki.ru/dk?st.cmd=userDiscussions&tkn=6986&st._aid=LeftColumn_Events_Discussions
   1 jar:file:///home/merhai/Downloads/firefox/chrome/toolkit.jar!/content/mozapps/extensions/extensions.xul
   1 http://www.tariqel3lm.com/vb/forum.php
   1 http://www.rarewares.org/mp3-lame-bundle.php
   1 http://www.programme-tv.net/programme/divertissement/2180293-taratata/
   1 http://www.nogomi.me/radio/nowplaying.asp
   1 http://www.cdiscount.com/telephonie/telephone-fixe/les-telephones-dect/sagem/l-144210113.html
   1 http://static.ak.facebook.com/common/redirectiframe.html
   1 http://muare.vn/f_87-LinhKien/page-4
   1 http://ftp.sh.cvut.cz/MIRRORS/pclinuxos/live-cd/english/preview/pclinuxos-openbox-2010.iso
   1 http://d-profi.kz/category_121.html

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 500105

Updated

9 years ago
blocking2.0: ? → ---

Updated

8 years ago
Status: RESOLVED → VERIFIED
Crash Signature: [@ GraphWalker<scanVisitor>::DoWalk(nsDeque&) ]
Comment hidden (spam)
Comment hidden (spam)
Comment hidden (spam)
You need to log in before you can comment on or make changes to this bug.