Filtered HTML parser stripping whitelisted tags

RESOLVED DUPLICATE of bug 570483

Status

RESOLVED DUPLICATE of bug 570483
8 years ago
4 years ago

People

(Reporter: ian, Unassigned)

Tracking

Details

(Whiteboard: Drumbeat Beta, URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9
Build Identifier: 2010-06-03

Some existing tags, mostly related to creating new lines, are getting stripped from out of Filtered html content on drumbeat project pages. Since "Filtered html" is now the default and only option for input format, this has resulted in a number of very ugly pages. 

The prime example is <p>

Reproducible: Always

Steps to Reproduce:
1. Add <p></p> tags to text
2. Save
3. Reload
Actual Results:  
View source reveals that the <p></p> tags are still there, but the text is not being rendered accordingly, i.e. no line breaks or new lines accompany the </p> tag. Text simply flows together as if all in one giant paragraph

Expected Results:  
line breaks after </p> tags, blank lines between </p> and <p>

Some other tags lose new lines as well. When the text display type initially moved exclusively to filtered html, </ul> produced a blank line. Now it no longer does. <h1,2,3,etc> Produce new lines as expected, as does <dd>, though <dl> does not.

Updated

8 years ago
Whiteboard: Drumbeat Beta

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 570483
(Assignee)

Updated

4 years ago
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.