Download progress for add-on updates disappears when viewing details page and going back

REOPENED
Unassigned

Status

()

defect
--
minor
REOPENED
9 years ago
a year ago

People

(Reporter: grenavitar, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewrite])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100603 Minefield/3.7a5pre ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100603 Minefield/3.7a5pre ( .NET CLR 3.5.30729)

Add-Ons Manager Update UI disappears when you visit add-on details, but the add-on still installs.

Reproducible: Always

Steps to Reproduce:
1) Install an old version of an add-on, click update all add-ons, wait until that add-on starts updating (easier to reproduce with an add-on that takes longer to download)
2) Double click / Show more information on Add-on (shows normal interface, no updating UI)
3) Click "Back to extensions"
Actual Results:  
4a) Instead of seeing the Add-on downloading it looks normal as if no update is in progress
4b) When Add-on finishes downloading you get the red outline but no restart butt... only the normal disable / uninstall buttons. (see attached)


Expected Results:  
Clicking back to extensions should have shown the progress bar of the Add-on downloading and when it was finished the red outline should have come as well as the restart button.
(Reporter)

Updated

9 years ago
Blocks: 550048
(Reporter)

Comment 1

9 years ago
Note: If you close AOM and then reopen/reload add-ons part of AOM the dialogue will read "Restart" instead of remove / disable.
(Reporter)

Updated

9 years ago
Component: General → Add-ons Manager
Product: Firefox → Toolkit
Version: unspecified → Trunk
So refreshing the AOM did the trick to show what should have displayed? 

I was going to say not all add-ons should need restarts, I wondered if it had completed before you switched back over.  But it sounds like that is not the case from comment 1.
Which extension is it you tried?  Version?  What method did you use to install it?  It would help for trying to reproduce.
Do you have an example add-on we could use? And given your comment 0 you probably forgot to attach your screenshot?
Blocks: 562622
Whiteboard: [AddonsRewrite]
(Reporter)

Comment 5

9 years ago
(Reporter)

Comment 6

9 years ago
(In reply to comment #3)
> Which extension is it you tried?  Version?  What method did you use to install
> it?  It would help for trying to reproduce.

I used Weave, updating from 1.3 beta to 1.3.  I used the method of entering AOM, manually searching for updates and having it download.

(sorry about that!)
(In reply to comment #5)
> Created an attachment (id=449267) [details]
> AOM Error - should show restart

If you look at the menu gray bar in the AOM it says it was downloaded and shows restart now to complete installation.  

Was Weave beta installed before?  And I guess the question is should the gray bar and the circled add-on show the button behavior in this case?

I guess if an add-on was already installed, I could see the old version was still able to be removed/disabled (detail area) at this stage of the upgrade, and the new version is waiting for restart (header area) based on the scenario.
(Reporter)

Comment 8

9 years ago
It does say that at the top, but shouldn't the bottom look like it does in this screenshot?
QA Contact: general → add-ons.manager
The case for the restart button is fixed. We simply do not show the download progress under such a condition. Updating summary to reflect the current behavior.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Summary: AOM Update UI disappears when you view details page--add-on still installs. → Download progress for add-on updates disappears when viewing details page and going back

Comment 10

a year ago
Per policy at https://wiki.mozilla.org/Bug_Triage/Projects/Bug_Handling/Bug_Husbandry#Inactive_Bugs. If this bug is not an enhancement request or a bug not present in a supported release of Firefox, then it may be reopened.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INACTIVE
Status: RESOLVED → REOPENED
Resolution: INACTIVE → ---
You need to log in before you can comment on or make changes to this bug.