Last Comment Bug 570321 - spell-check-dictionary name is not displayed in context menu
: spell-check-dictionary name is not displayed in context menu
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla1.9.3a5
Assigned To: :Ehsan Akhgari (busy, don't ask for review please)
:
Mentors:
Depends on:
Blocks: 433860 593575
  Show dependency treegraph
 
Reported: 2010-06-05 09:26 PDT by Alice0775 White
Modified: 2010-09-04 04:42 PDT (History)
7 users (show)
ehsan: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
alpha5+
.7+
.7-fixed
.11+
.11-fixed


Attachments
Patch (v1) (2.57 KB, patch)
2010-06-05 20:23 PDT, :Ehsan Akhgari (busy, don't ask for review please)
gavin.sharp: review+
christian: approval1.9.2.7+
christian: approval1.9.1.11+
Details | Diff | Review

Description Alice0775 White 2010-06-05 09:26:40 PDT
spell-check-dictionary name is not displayed in context menu.

Reproducible: Always

Steps to Reproduce:
1. Start Minfield/Namoroka with new profile
2. Right click on textarea
3. Chose "Languages >"

Actual Results:
 spell-check-dictionary name is not displayed in context menu

Expected Results:
 spell-check-dictionary name ishould be displayed in context menu

Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100603 Minefield/3.7a5pre ID:20100603110311

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dc913bfadfd0&tochange=25442798da4a
Candidate bug:
Bug 433860  - No spelling suggestions for text inputs when contenteditable node in document

And Namoroka is also broken.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6pre) Gecko/20100605 Namoroka/3.6.6pre ID:20100605042233

But Shiretoko is fine.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.11pre) Gecko/20100605 Firefox/3.5.11pre ID:20100605045013
Comment 1 Alice0775 White 2010-06-05 09:30:51 PDT
It seems to be fixed the following modification for 
toolkit/content/InlineSpellChecker.jsm


-      item.label = displayName;
+      item.setAttribute("label", displayName);
Comment 2 Alice0775 White 2010-06-05 09:36:04 PDT
And see forum http://forums.mozillazine.org/viewtopic.php?p=9458117#p9458117
Comment 3 XtC4UaLL [:xtc4uall] 2010-06-05 11:00:11 PDT
Alice, you learned how to create MQ based patches finally & thus can attach one for review?
btw, you rock! :-)
Comment 4 XtC4UaLL [:xtc4uall] 2010-06-05 11:07:49 PDT
while testing comment 0 (enabling 'check spelling', check for the languages, disabling 'check spelling') and writing comment 3 i crashed:

bp-afc49e3f-9a06-465b-944e-e10192100605
[@ nsTextServicesDocument::NodeHasOffsetEntry(nsTArray<OffsetEntry*>*, nsIDOMNode*, int*, int*) ]
Comment 5 Alice0775 White 2010-06-05 11:26:25 PDT
(In reply to comment #3)
> Alice, you learned how to create MQ based patches finally & thus can attach one
> for review?
I think that it is difficult for me.
Comment 6 :Ehsan Akhgari (busy, don't ask for review please) 2010-06-05 13:33:37 PDT
(In reply to comment #4)
> while testing comment 0 (enabling 'check spelling', check for the languages,
> disabling 'check spelling') and writing comment 3 i crashed:
> 
> bp-afc49e3f-9a06-465b-944e-e10192100605
> [@ nsTextServicesDocument::NodeHasOffsetEntry(nsTArray<OffsetEntry*>*,
> nsIDOMNode*, int*, int*) ]

Filed bug 570350 for this crash.
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2010-06-05 20:23:38 PDT
Created attachment 449497 [details] [diff] [review]
Patch (v1)

OK, the problem is that when the menuitem is created, the XBL for it is not bound, so setting the property does not set the attribute on the item.  I originally did that because inside test_contextmenu.html, item.label would sometimes be undefined.  I figured out that we don't bind menuitem XBLs for items in menus which are not displayed, and that was the reason why item.label was sometimes undefined.  So I made the test use getAttribute as well, and all is good now.
Comment 8 :Ehsan Akhgari (busy, don't ask for review please) 2010-06-05 20:24:20 PDT
1.9.2.5 should come out with this patch, so that we don't ship a broken menu item to our users.
Comment 9 :Ehsan Akhgari (busy, don't ask for review please) 2010-06-08 08:19:07 PDT
http://hg.mozilla.org/mozilla-central/rev/0ba3b3e08dfb
Comment 10 alex_mayorga 2010-06-10 07:48:39 PDT
I can now see the spell-check-dicktionary name on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a5pre) Gecko/20100610 Minefield/3.7a5pre ID:20100610035756
Comment 11 christian 2010-06-11 15:25:35 PDT
Comment on attachment 449497 [details] [diff] [review]
Patch (v1)

a=LegNeato for 1.9.2.6 and 1.9.1.11. Please land this on mozilla-1.9.2 default and mozilla-1.9.1 default.
Comment 12 :Ehsan Akhgari (busy, don't ask for review please) 2010-06-13 11:56:50 PDT
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/1d878086b53b

Holding off on 1.9.1 landing until bug 433860 gets into 1.9.1.
Comment 13 :Ehsan Akhgari (busy, don't ask for review please) 2010-06-13 14:08:28 PDT
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/e889ceb68a15
Comment 14 Gabriela [:gaby2300] 2010-07-09 20:21:28 PDT
I can't reproduce on 3.6.7

Note You need to log in before you can comment on or make changes to this bug.