No warning sending mail with Latin2 (ISO-8859-2) chars in the Organisations, From or To header

VERIFIED DUPLICATE of bug 44313

Status

MailNews Core
Internationalization
P3
normal
VERIFIED DUPLICATE of bug 44313
17 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: nhottanscp)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If you go in to the Account Settings and enter:
"urèen"   (a word with ISO-8859-2 chars)
into the Organisation field and and compose and new mail and send it the 
Organisation header is incorrectly encoded with ISO-8859-1:
Organization: =?ISO-8859-1?Q?urc=28en?=

My default in composing a new mail is ISO-8859-1.

Normally if you enter ISO-8859-2 chars into the mail and the Character Coding is 
set to ISO-8859-1 you get a warning.
(Reporter)

Comment 1

17 years ago
The same thing goes for the From header.
Thats ISO-8859-2 chars in the Your Name field
Summary: No warning sending mail with with Latin2 (ISO-8859-2) chars in the Organisations header → No warning sending mail with with Latin2 (ISO-8859-2) chars in the Organisations or From header
(Reporter)

Comment 2

17 years ago
And the same goes for the To header...
Should this type of bugs be filed in I18N instead?
Summary: No warning sending mail with with Latin2 (ISO-8859-2) chars in the Organisations or From header → No warning sending mail with Latin2 (ISO-8859-2) chars in the Organisations, From or To header
Naoki, do you want to take care of this problem?
(Assignee)

Comment 4

17 years ago
Yes, currently the check is only done for subject and main body.
Assignee: ducarroz → nhotta
Component: Composition → Internationalization
QA Contact: esther → momoi
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Target Milestone: --- → M23

Updated

17 years ago
Keywords: intl

Comment 5

17 years ago
QA contact to ji.
QA Contact: momoi → ji
(Assignee)

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 44313 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
ok
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.