Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 570461 - Event Invitation Reply is not using original email address
: Event Invitation Reply is not using original email address
Status: RESOLVED DUPLICATE of bug 475886
Product: Calendar
Classification: Client Software
Component: E-mail based Scheduling (iTIP/iMIP) (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on:
  Show dependency treegraph
Reported: 2010-06-07 02:49 PDT by TS
Modified: 2010-10-13 11:55 PDT (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description TS 2010-06-07 02:49:00 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/2010031422 Firefox/3.0.19
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

Replies to event invitations are sent out using the email address of the calendar instead of the address it was sent to. I get invites on 2 email accounts and have only a single calendar. However I still expect that a reply uses the address of the invite instead of the address of the calendar.
If that is not possible I would at least expect a warning about getting invites for an account without a calendar assigned to it.

Reproducible: Always

Steps to Reproduce:
1. Setup 2 email accounts
2. Send separate invites to each account
3. Accept the invite(s)
4. Check the sent folders
Actual Results:  
Both replies appear in the same sent folder instead of 1 reply per account

Expected Results:  
A reply should be sent with the same address it was sent to.
Comment 1 BBG 2010-08-09 16:28:46 PDT
Me too but with a twist.  Thunderbird 3.1.2/Lightning 1.0b2.

The calendar is using an email address that not registered in Thunderbird or any contact list.  It is an alias on the Zimbra server and I have received an email with it, and it is in the email address cache  -- no other traces.  The Zimbra calendar functions properly and this does not happen using the Zimbra web or desktop interfaces.  

If I reply to or send a meeting invitiation from Lightning it is from "".  if I add that identity to Thunderbird no difference; if I delete it, no difference; if I rename it no difference.  Windows 7 x64 PC.

The properties for the calendar show my proper email address, but it is ignored.  The SpuriousEmail address is not shown as an option for calendar properties.
Comment 2 Bas van den Bosch 2010-10-13 11:55:33 PDT

*** This bug has been marked as a duplicate of bug 475886 ***

Note You need to log in before you can comment on or make changes to this bug.