Closed Bug 570464 Opened 10 years ago Closed 10 years ago

CalDAV Cached Calendar never completes sync / Deleting Metadata fails

Categories

(Calendar :: Provider: CalDAV, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Fallen, Assigned: Fallen)

Details

(Keywords: regression, Whiteboard: [needed beta][no l10n impact])

Attachments

(1 file)

With the experimental cache enabled, deleting metadata fails with an error message. The fix is quite simple.

Also we have numerous astonishing bugs in the caldav code which were never noticed. This patch fixes, and blocks 1.0b2.
Flags: blocking-calendar1.0+
Attached patch Fix - v1 β€” β€” Splinter Review
The promised patch
Attachment #449596 - Flags: review?(simon.at.orcl)
Comment on attachment 449596 [details] [diff] [review]
Fix - v1

r=simon but I think the notifyGetFailed call in "if (!this._reader) { }" in onStopRequest should be removed because if the reader is null it means that onStartRequest has already notified the caller of the failure (before setting _reader to null).
Attachment #449596 - Flags: review?(simon.at.orcl) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/c3c30b85849e>
-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
the latter comm-1.9.2 push was the 20100525 relbranch push. I took out the notifyGetFailed as noted in comment 2, and also fixed another 1-line bug in the storage calendar, where relations were not being deleted. dbo approved this chunk.
You need to log in before you can comment on or make changes to this bug.