Default drag feedback doesn't appear anymore in many cases

RESOLVED FIXED in mozilla1.9.3a5

Status

()

Core
Drag and Drop
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: dao, Assigned: tnikkel)

Tracking

({regression})

Trunk
mozilla1.9.3a5
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
For instance, links or images don't get the feedback, selected text however does. I noticed this today, probably regressed only a few days ago.
(Reporter)

Updated

8 years ago
Keywords: regressionwindow-wanted
There seem to be no June 6 mac nightlies, so the best range I get here is http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b219912edfec&tochange=5b3604a3cfbe

Bug 563878 is a plausible reason this might have broken....
Blocks: 563878
Keywords: regressionwindow-wanted
(Assignee)

Comment 2

8 years ago
Yeah, caused by part 1b (http://hg.mozilla.org/mozilla-central/rev/d5ca465f4238) of bug 563878.
(Assignee)

Comment 3

8 years ago
Created attachment 449746 [details] [diff] [review]
patch

The clip region we pass to PresShell::RenderNode in nsBaseDragService::DrawDrag was changed to be a stack variable from a pointer. So we end up passing an empty region in all the cases we used to pass null.
Assignee: nobody → tnikkel
Attachment #449746 - Flags: review?(matspal)
Comment on attachment 449746 [details] [diff] [review]
patch

r=mats
Attachment #449746 - Flags: review?(matspal) → review+
(Assignee)

Comment 5

8 years ago
http://hg.mozilla.org/mozilla-central/rev/12ea060fa735
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Target Milestone: --- → mozilla1.9.3a5

Updated

8 years ago
Summary: Default drag feedback doesn't appear anymore in may cases → Default drag feedback doesn't appear anymore in many cases

Updated

7 years ago
blocking2.0: ? → final+
You need to log in before you can comment on or make changes to this bug.