Closed Bug 570603 Opened 10 years ago Closed 10 years ago

Autocomplete should search while composing on Android

Categories

(Toolkit :: Autocomplete, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fennec 2.0a1+ ---

People

(Reporter: mwu, Assigned: jchen)

References

Details

(Keywords: inputmethod)

Attachments

(2 files)

autocomplete.xml currently doesn't handle the text event, so no searches are performed while the user is using an IME to input text.
Attachment #449734 - Flags: review?(gavin.sharp)
Comment on attachment 449734 [details] [diff] [review]
Autocomplete on text events

Somehow this manages to break the normal case..
Attachment #449734 - Flags: review?(gavin.sharp)
This is not a bug, see bug 165055.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
screenshots on Safari.
http://www.d-toybox.com/studio/weblog/show.php?mode=single;id=2009030700

If we open the autocomplete candidate window, we have very big a11y problem.
This is a serious problem on mobile (in particular, Android). We don't have control over whether the softkb gives us autocomplete. The location bar will not complete properly until the compose is completed, which is bad. If this fix will have to be mobile/android only, that's fine.
Status: RESOLVED → REOPENED
OS: All → Android
Resolution: INVALID → ---
Summary: Autocomplete should search while composing → Autocomplete should search while composing on Android
tracking-fennec: --- → 2.0+
tracking-fennec: 2.0+ → 2.0a1+
mwu:

I basically moved your patch to mobile-browser. Mobile-browser has a binding for autocomplete that inherits from toolkit.

Seems to work well on Android, but I don't know how to test on Maemo (we can also just make this Android-only).
Assignee: mwu → jchen
Attachment #459149 - Flags: feedback?(mwu)
Comment on attachment 459149 [details] [diff] [review]
Autocomplete during composition (mobile only) v2

If it works ok on desktop it should be fine on Maemo.
Attachment #459149 - Flags: feedback?(mwu) → feedback?(mark.finkle)
Comment on attachment 459149 [details] [diff] [review]
Autocomplete during composition (mobile only) v2

Tested on desktop with ibus-py IME
Attachment #459149 - Flags: feedback?(mark.finkle) → review?(mark.finkle)
Why move this to mobile only? Is it because of the accessibility issue Masayuki points out?
Right. It's desirable on mobile but not desirable on desktop. On a desktop the autocomplete popup might cover up anything that the IME displays. On mobile, (Android at least) we make room for the IME display so it's not a problem.
Attachment #459149 - Flags: review?(mark.finkle) → review+
mfinkle: Can you land this? Thanks!
pushed:
http://hg.mozilla.org/mobile-browser/rev/382f1d7d5999
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Backing out this patch. It seems to have broken autocomplete on Android
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 576065
Ready to be pushed again since bug 576065 landed.
pushed again: http://hg.mozilla.org/mobile-browser/rev/dbfee3e7fa90
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.