Please implement DOM Level 3 Events

RESOLVED DUPLICATE of bug 256333

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 256333
7 years ago
7 years ago

People

(Reporter: Michael Spector, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Opera/9.80 (Windows NT 6.0; U; en) Presto/2.5.24 Version/10.53
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

I wonder what's the plan regarding the implementation of DOM Level Events (http://www.w3.org/TR/2002/WD-DOM-Level-3-Events-20020208/changes.html). Personally, I'd like to see eventListenerList implemented, since there's now API currently to determine all attached event listeners.

Reproducible: Always
Yes, there is a slow progress to implement DOM 3 Events. But what you're looking
is some very old document. 
The latest draft is in http://dev.w3.org/2006/webapi/DOM-Level-3-Events/html/DOM3-Events.html and that draft doesn't have eventListenerList.

If you're developing an extension, you could look at bug 448602 to see
how to enumerate listeners.
(Reporter)

Comment 2

7 years ago
Thanks, that helped me a lot.

(In reply to comment #1)
> 
> If you're developing an extension, you could look at bug 448602 to see
> how to enumerate listeners.

Comment 3

7 years ago
How does this bug relate to bug 256333?

Looks like a dup to me.
Yeah.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 256333
You need to log in before you can comment on or make changes to this bug.