Closed Bug 570876 Opened 13 years ago Closed 12 years ago

rename the Jetpack SDK to "Add-on SDK"


(Add-on SDK Graveyard :: General, defect, P2)



(Not tracked)



(Reporter: myk, Assigned: myk)



(1 file, 1 obsolete file)

We should rename the Jetpack SDK to the Add-ons Builder SDK so that it is consistent with the name of the Add-ons Builder website we're developing over in the FlightDeck project.

The name of the actual downloadable bundles should be addons-builder-sdk-[version].[ext], f.e.:


Alternately, perhaps we can strip "sdk" from them, simplifying the names to addons-builder-[version].[ext], f.e.:


After all, it seems likely that anyone clicking a "Download the Add-ons Builder SDK" link/button and downloading something called would understand that the bundle they downloaded is the SDK, even though it doesn't include "sdk" in its filename.

The current process for generating the bundles involves using Mercurial's built-in tag-bundling feature, whereby loading a special URL with a tag in it creates and downloads a bundle named after a combination of the repository and the tag.

For example, the URL <> generates a bundle that expands to a jetpack-sdk-0.4 directory.

So we'll need to figure out what to do about that (rename the repository? use a different process for building the bundle?).

Drew said he could take this on for 0.5.  Based on further discussions with Mayumi regarding coordinating this renaming with the launching of the public beta of the website, it sounds like we'll delay this until 0.6, though.
Update: the web app has been renamed Add-on Builder (where "add-on" is singular), so this should be called Add-on Builder SDK.

I also recently pinged Mayumi to ask whether or not she thought it would make sense to shorten to simply "Add-on SDK", as I'd heard a few folks spontaneously shorten it to that phrase in casual conversation.  I'm waiting to hear back from her on that.
Summary: rename the Jetpack SDK to Add-ons Builder SDK → rename the Jetpack SDK to Add-on Builder SDK
I vote for the shorter version:

"the Firefox Add-on SDK" sounds far clearer than "Firefox Add-on Builder SDK".

The latter is the SDK for the Firefox Add-on Builder.
I vote too for:

"Firefox Add-on SDK"

I like so much is short and so clear, says what the product is =).
+1 for "Add-on SDK"
(In reply to comment #4)
> +1 for "Add-on SDK"

+1 "Add-on SDK"
Mayumi and I talked through the various issues and agreed to rename the product to "Add-on SDK", although we will continue to market alongside Add-on Builder, targeting Add-on Builder to the large audience of casual developers that we are going to be trying to reach with many of our promotions, with the SDK being the product we suggest for the smaller group of professional developers for whom it is more appropriate.
Summary: rename the Jetpack SDK to Add-on Builder SDK → rename the Jetpack SDK to "Add-on SDK"
Assignee: nobody → myk
Priority: -- → P2
Target Milestone: -- → 0.8
Attached patch patch v1: implements change (obsolete) — Splinter Review
I think this is good to go, although there might be some remaining issues, given that every occurrence required individual evaluation to see whether it should be replaced by "SDK", "SDK-based", or some other construction.  Notes:

1. it doesn't touch code references for the most part, as it's ok for them to reference Jetpack, since they aren't user-facing (although we might want to avoid them in the future);
2. it does rename to addon-sdk-docs.tgz (will that mess up FlightDeck integration?);
3. LLJAPI -> LLSAPI (low-level SDK API), but perhaps it should just be LLAPI (low-level API);
4. Jetpack Program -> Program, but perhaps it should be SDK Program.
Attachment #475127 - Flags: review?(avarma)
Comment on attachment 475127 [details] [diff] [review]
patch v1: implements change

Urgh, sorry, this patch has rotted. :(  Can you rebust it?

Also, I feel a bit weird calling this the "Add-on SDK", if only because that's a rather generic name for a product--if it were used in a sentence comparing it to other technologies, for instance, it'd be ambiguous what it'd be referring to. We can't call it the "Mozilla Add-on SDK" or the "Firefox Add-on SDK"?

"Low-Level SDK API" and "Low-Level API" sound similarly vague, and particularly liable to get confused with Mozilla's other APIs, which they're likely to be used in the same sentence with.  Novice add-on developers won't need to see the term (we can hide the LLJAPI guide in a "SDK internals" section), but it's likely that folks who have to read it will also need to have knowledge of Gecko topics like XUL, XPCOM, and so forth. A sentence combining all these terms could make "low-level API" start to sound ambiguous, as though it can refer to either a NSPR API or an XPCOM API, when in fact it refers to something particular to the Jetpack platform.

I guess I am just confused as to why we are not only dropping the term "Jetpack" entirely, but also making the name of the product terribly generic, allowing it to become easily confused with any other software development kit for creating add-ons for any kind of application. I'd also note that the concept of naming a platform something unambiguous isn't unusual--OS X, for instance, has APIs called "Cocoa" and "Carbon", the Chrome Extensions API is always qualified with the product name "Chrome", and so forth.

Anyhow, I could also just be misinterpreting the purpose of this renaming or something. I also voiced some of my confusions about this in bug 595407 comment 1, so it might be useful to have a quick meeting about this, or something.
Attachment #475127 - Flags: review?(avarma) → review-
(In reply to comment #8)
> Comment on attachment 475127 [details] [diff] [review]
> patch v1: implements change
> Urgh, sorry, this patch has rotted. :(  Can you rebust it?


> Anyhow, I could also just be misinterpreting the purpose of this renaming or
> something. I also voiced some of my confusions about this in bug 595407 comment
> 1, so it might be useful to have a quick meeting about this, or something.

Atul and I met about this, and I explained the reasoning behind the renaming, the summary of which is that we are giving the product a descriptive name that will allow our target audience to easily identify its purpose, that doesn't require us to build yet another brand, and to which we can prepend qualifiers (like "Mozilla's Add-on SDK" or "the Add-on SDK for Firefox") in contexts in which the scope of the name is unclear.

This patch also simplifies terminology as appropriate, including removing from the glossary those definitions of terms that don't actually appear anywhere in the SDK documentation.

The equivalent pull request is
Attachment #475127 - Attachment is obsolete: true
Attachment #488591 - Flags: review?(avarma)
Comment on attachment 488591 [details] [diff] [review]
patch v2: unrotted

This looks great, thanks. I've pushed them to the main repo here by merging myk's branch for this bug, as all his changesets divided the problem up into several easily-digestible pieces:

The commit makes it look like I was the author of all the changes, but it's just a merge commit--the real changes leading up to the merge are authored by Myk and are still attributed to him in the repo's metadata.
Attachment #488591 - Flags: review?(avarma) → review+
Closed: 12 years ago
Resolution: --- → FIXED
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
You need to log in before you can comment on or make changes to this bug.