Items can't be dragged in Chrome experiment Google gravity

RESOLVED DUPLICATE of bug 54341

Status

()

Core
General
RESOLVED DUPLICATE of bug 54341
8 years ago
8 years ago

People

(Reporter: Barak Gross, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100608 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100608 Minefield/3.7a5pre

In the latest nightly, the performance of this test is now greatly improved but there's still one aspect Chrome is better at:
In Chrome items can be dragged and thus have their physics "properties" shown, this does not work in Firefox

Reproducible: Always

Steps to Reproduce:
1. Open URL
2. Drag one of the items on screen
Actual Results:  
No item can be dragged

Expected Results:  
Items should be draggable
Need to figure out where in that mess of js and browser-sniffing things are going awry.  I can confirm the lack of draggability, but it seems rather likely to be a site issue.
Keywords: qawanted
I'm seeing these errors in the error console:
Error: window.event is undefined
Source File: http://mrdoob.com/projects/chromeexperiments/google_gravity/js/Main.js
Line: 158

In the js file Main.js, this function is going wrong:

function onDocumentMouseMove() {

	if (!isRunning)
		run();

	mouseX = window.event.clientX;
	mouseY = window.event.clientY;
}

Mozilla doesn't support window.event.

So I would say this is a duplicate of bug 54341.
Ah, indeed.  Just the site assuming the IE event model.  Not sure how I missed that!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 54341
You need to log in before you can comment on or make changes to this bug.