MathML: Radicals don't stretch vertically down back to the baseline

RESOLVED DUPLICATE of bug 569195

Status

()

defect
RESOLVED DUPLICATE of bug 569195
9 years ago
9 years ago

People

(Reporter: cse777, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Using recommended STIX fonts, any radical symbol over an mfrac (or any other large symbol) fails to stretch down to the fonts baseline.

Reproducible: Always

Steps to Reproduce:
Try to render this simple expression:
<math xmlns="http://www.w3.org/1998/Math/MathML" display="block">
  <mstyle displaystyle="true">
    <msqrt>
      <mstyle class="radicand">
        <mfrac>
          <mn>1</mn>

          <mi>x</mi>

        </mfrac>
      </mstyle>
    </msqrt>
  </mstyle>
</math>
Reporter

Comment 1

9 years ago
Or this even simpler one:
<math xmlns="http://www.w3.org/1998/Math/MathML" display="block">
    <msqrt>
        <mfrac>
          <mn>1</mn>
          <mi>x</mi>
        </mfrac>
    </msqrt>
</math>
Are you using STIX Beta or 1.0 fonts?
Reporter

Comment 3

9 years ago
I have already switched to STIX 1.0
Was this premature?
There are some differences in STIX 1.0 for which we need to make changes.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569195
You need to log in before you can comment on or make changes to this bug.