Closed Bug 571108 Opened 10 years ago Closed 10 years ago

Observers in Password Manager UI don't work

Categories

(Toolkit :: Password Manager, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 395681

People

(Reporter: kairo, Unassigned)

Details

I tried to copy from the observers in the Password Manager UI for my work in Data Manager, as it's hard to find the topic to observe, and I found out that not even that UI updates when passwords are added, changed, removed or sites blocked.
http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/components/passwordmgr/content/passwordManagerCommon.js#69 obviously doesn't listen the right way, and that should be fixed.
I also think that "signonSelectUser" doesn't actually exist as a topic anywhere, btw.
OS: Linux → All
Hardware: x86 → All
Hmm, this is true. For the "signonChanged" topic, I guess "passwordmgr-storage-changed" fills that gap. It's the topic sent when a login as been added/removed/modified or when all logins have been removed or host saving enabled/disabled. Look through http://mxr.mozilla.org/mozilla-central/source/toolkit/components/passwordmgr/src/storage-mozStorage.js for _sendNotification for the various use cases.

For "signonSelectUser", not sure what that was even for based on the comment in there. I guess there was a dialog for selecting users and so it would prevent deleting a possibly in use login... I don't know that there's a corresponding topic nowadays...
I found out about "passwordmgr-storage-changed" for my own use in Data Manager now, yes, but I wanted to make sure this is filed so the toolkit password manager can be fixed as well.

"signonSelectUser" probably was for that selection window we had with the old non-JS password manager, yes, and we should just eliminate that, as that is gone for good.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395681
You need to log in before you can comment on or make changes to this bug.