Last Comment Bug 571313 - [OOPP] Flash video player: Play button (overlay) on screen does not disappear
: [OOPP] Flash video player: Play button (overlay) on screen does not disappear
Status: VERIFIED WORKSFORME
[oopp-watchlist]
: relnote
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 1.9.2 Branch
: x86_64 Windows Vista
: -- normal with 4 votes (vote)
: ---
Assigned To: Jim Mathies [:jimm]
:
Mentors:
http://www.bild.de/BILD/video/clip/di...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 13:10 PDT by Markus Multrus
Modified: 2011-03-07 12:17 PST (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
needed
wanted


Attachments
Screenshot demonstrating the problem (185.14 KB, image/jpeg)
2010-06-10 13:17 PDT, Markus Multrus
no flags Details

Description Markus Multrus 2010-06-10 13:10:50 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.4) Gecko/20100527 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.4) Gecko/20100527 Firefox/3.6.4

Playing the video on the given side, the play-button (which overlays the video, and usually disappears when the video is played-back) does not disapper any more. Works on the same machine with FF 3.6.3.

Note: The video is from Germany's #1 yellow press page

Reproducible: Always

Steps to Reproduce:
1. Open Page
2. Try to play video, by clicking on the play button which overlays the screen in the beginning or press the play button in the navigation bar below
3. The overlayed play button does not disappear, and overlays the video during playback
Comment 1 Markus Multrus 2010-06-10 13:17:18 PDT
Created attachment 450427 [details]
Screenshot demonstrating the problem

The red arrow indicates the overlay play button, which is supposed to disappear
Comment 2 Markus Multrus 2010-06-10 13:20:28 PDT
Flash player version info:
Version: 10.0.45.2
Shockwave Flash 10.0 r45
Comment 3 aravindm 2010-06-11 01:56:40 PDT
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a5pre) Gecko/20100610 Minefield/3.7a5pre
Able to reproduce the issue. Play button is overlayed on the video. Tested in firefox 3.6.4 branch also.

Shockwave Flash
    File: NPSWF32.dll
    Version: 10.1.53.64
    Shockwave Flash 10.1 r53
Comment 4 aravindm 2010-06-11 01:59:10 PDT
Build worked :
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.4pre) Gecko/20100406 Namoroka/3.6.4pre
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/965a31dcde02

Build broken :
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.4pre) Gecko/20100407 Lorentz/3.6.4pre
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/ec534329e186

Pushlog : 
http://hg.mozilla.org/releases/mozilla-1.9.2/pushloghtml?fromchange=965a31dcde02&tochange=ec534329e186
Comment 5 Markus Multrus 2010-06-11 06:58:15 PDT
Maybe it's worth mentioning that the website "bild.de", where the video origins from, is on Alexa's #11 for Germany and #190 worldwide. So, it's certainly not as critical as youtube, but there might be a larger audience in Germany facing this problem.
Comment 6 christian 2010-06-11 14:33:11 PDT
I can't reproduce this on Windows 7 64 bit. Still trying...
Comment 7 christian 2010-06-11 14:36:52 PDT
I also updated to Flash 10.1 and still can't reproduce. I'm using a VM though so results may be different.
Comment 8 Markus Multrus 2010-06-11 14:40:04 PDT
Hm, I can reproduce this with both, Flash 10.0.45.2
 and Flash 10.1 (update from yesterday), on a native Win Vista 64bit installation
Comment 9 Mike Beltzner [:beltzner, not reading bugmail] 2010-06-11 14:45:53 PDT
Markus: please go to about:support and let us know what addons you have. I can't reproduce this on a Windows 7 system running natively.

I think this is "worksforme"
Comment 10 Markus Multrus 2010-06-11 14:54:06 PDT
My extensions:

Adblock Plus	1.2	true	{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Deutsches Wörterbuch	2.0.1	true	de-DE@dictionaries.addons.mozilla.org
Firebug	1.5.4	true	firebug@software.joehewitt.com
Microsoft .NET Framework Assistant	0.0.0	true	{20a82645-c095-46ed-80e3-08825760534b}
NoScript	1.9.9.81	true	{73a6fe31-595d-460b-a920-fcc0f8843232}
Personas	1.5.3	true	personas@christopher.beard
United States English Dictionary	4.0.0	true	en-US@dictionaries.addons.mozilla.org
User Agent Switcher	0.7.2	true	{e968fc70-8f95-4ab9-9e79-304de2a71ee1}
Java Console	6.0.16	true	{CAFEEFAC-0016-0000-0016-ABCDEFFEDCBA}
Java Console	6.0.20	true	{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}

I'll try to reproduce with a fresh profile... What's about aravindm? Seems he can reproduce?
Comment 11 christian 2010-06-11 14:55:50 PDT
Could be Vista-specific...
Comment 12 Mike Beltzner [:beltzner, not reading bugmail] 2010-06-11 14:58:30 PDT
Correction: I was using Vista, not Windows 7, so yeah, marking this WORKSFORME.
Comment 13 Mike Beltzner [:beltzner, not reading bugmail] 2010-06-11 14:59:52 PDT
Markus, please try in a new profile, re-open if you still see it, yeah.
Comment 14 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-11 15:02:11 PDT
I can reproduce this on Windows 7 Ultimate 64-bit running natively with Flash 10.1 using 3.6.4build6.  This is a completely fresh install of Windows and hadn't installed Firefox on it yet, so this is a brand spanking new profile.
Comment 15 Markus Multrus 2010-06-11 15:03:24 PDT
Even with a brand new profile I can reproduce. Here is my extension list:

Java Console	6.0.16	true	{CAFEEFAC-0016-0000-0016-ABCDEFFEDCBA}
Java Console	6.0.20	true	{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
Microsoft .NET Framework Assistant	0.0.0	true	{20a82645-c095-46ed-80e3-08825760534b}

Shockwave Flash
Version: 10.1.53.64
Shockwave Flash 10.1 r53

Mike: are you using Vista x86_64?

Re-opening: sorry for the trouble...
Comment 16 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-11 15:04:01 PDT
Interesting note:  If I reload the page, the red arrow goes away when clicking it.
Comment 17 Mike Beltzner [:beltzner, not reading bugmail] 2010-06-11 15:04:12 PDT
Markus: what version of Windows are you running? 32-bit or 64-bit?
Comment 18 Markus Multrus 2010-06-11 15:07:51 PDT
64-bit
Comment 19 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-11 15:09:38 PDT
I can definitely reproduce this reliably, but it requires a new profile:

1. Start Firefox with a new profile
2. Load the test site
3. Click the red arrow to play (arrow stays)
4. Reload the page
5. Click the red arrow to play (arrow disappears)

NOTE: Win7 Ultimate 64-bit, 3.6.4build6 32-bit, Flash 10.1.53.64
Comment 20 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-11 15:17:24 PDT
I jumped to conclusions a bit on my last comment.  When reloading the site in step 4, an ad begins playing.  The ad does not show the red arrow.  Once the test video gets queued up, the red arrow reappears and stays.
Comment 21 Markus Multrus 2010-06-11 15:23:49 PDT
Anthony: same behavior for me
Comment 22 (mostly gone) XtC4UaLL [:xtc4uall] 2010-06-11 17:40:38 PDT
fwiw, i can repro this with WinXP/Flash 10.1.53.64 both on today's 1.9.2 and .3 nightly builds.
Comment 23 christian 2010-06-14 16:11:28 PDT
I wonder if this is related to bug 570267?
Comment 24 j_oyen 2010-07-17 19:40:35 PDT
I am on Windows XP Service Pack 3 and have the same problem.  Any idea when this issue will be fixed ??
Comment 25 Mike Smith 2010-07-18 20:09:12 PDT
I've noticed what sounds like the same problem on OS X 10.4.11.
Lately, BBC news videos retain the "Play" arrow while playing, unless I click on the video (which pauses) then click again to resume.  The play arrow disappears after that. (FF3.6.3, Flash 10.0.45.2)
Comment 26 Cole Navarro 2010-07-30 10:58:08 PDT
the latest version of firefox 3.6.8 the flash player always crashed when a video start to load its works fine in youtube.com but the others site like http://veoh.com, http://onepieceofbleach.com and http://anime44.com its not loading its always flash player crash then i disable the crashed protection then try again if its works but firefox is not responding my flash player version is 10.1.53.64 
please fix problem
Comment 27 (mostly gone) XtC4UaLL [:xtc4uall] 2010-07-30 15:03:41 PDT
(In reply to comment #22)
> fwiw, i can repro this with WinXP/Flash 10.1.53.64 both on today's 1.9.2 and .3
> nightly builds.

The Example listed in the URL Field is WFM now with current Trunk Build Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100730 Minefield/4.0b3pre ID:20100730040228, i.e. the overlayed Pause/Play Buttons work correctly.
Gonna search for a Progression Range at Weekend.

@Cole: this is not the right Place for your Issue. Please try http://support.mozilla.com.
Comment 28 (mostly gone) XtC4UaLL [:xtc4uall] 2010-09-06 16:02:41 PDT
This is WFM either using
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 (the Build this Report was filed against with)
or
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.10pre) Gecko/20100906 Namoroka/3.6.10pre
or
Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100906 Firefox/4.0b6pre
(Built from http://hg.mozilla.org/mozilla-central/rev/c3e21097bb78)
and Adobe Shockwave Flash 10.1.82.76.

Thus this seems to have been a Site/Flash Issue.
Feel free to Reopen if you have evidence against this.
Comment 29 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-09-22 10:02:48 PDT
Marking VERIFIED based on today's nightly.
Comment 30 Shane Bundy 2011-03-04 14:14:27 PST
Someone using the nightlies experienced this recently on their XP system with an Intel 945. It would work the first time it was loaded but if the page got reloaded this problem would occur. It was first noticed on YouTube.
Comment 31 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-03-04 14:50:35 PST
(In reply to comment #30)
> Someone using the nightlies experienced this recently on their XP system with
> an Intel 945. It would work the first time it was loaded but if the page got
> reloaded this problem would occur. It was first noticed on YouTube.

When it comes to plugin bugs, it's always important to know what version of the plugin was being used (in this case, Flash).


Additionally, I believe this was related to the www.bild.de flash player and not any other flash player. If someone is experiencing a similar issue, it should probably be raised in a new bug.
Comment 32 Shane Bundy 2011-03-05 09:23:20 PST
The version of Flash used is 10.2.152.30 and this is with the latest nightly. I don't think a new bug should be raised as this bug is generalised. I'll send a screen grab soon along with the plugins in use.
Comment 33 Steff 2011-03-06 11:28:09 PST
before I upgraded flash player, everything was normal. When I upgraded the newest flash player, I couldn't watch any video on Youtube. I see a white square where the video is supposed to be, I can hear the sound but I want to watch again. Please fix this!
Comment 34 (mostly gone) XtC4UaLL [:xtc4uall] 2011-03-06 14:29:30 PST
Please guys, file new Reports. This one is done. No need for any further Comments.

Note You need to log in before you can comment on or make changes to this bug.