Closed Bug 571314 Opened 9 years ago Closed 9 years ago

Get a master/slave DB set up for support-stage-new

Categories

(mozilla.org Graveyard :: Server Operations, task, critical)

All
Other
task
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jsocol, Assigned: tellis)

References

Details

Having a non-production environment with replication would have allowed us to see the issues with our 2.1 push (see bug 570656) before the push.

This isn't urgent but it would help us test and ensure good pushes.

In trade, I'm also going to file a bug to decomission the old support-stage.
Assignee: server-ops → tellis
Blocks: 571368
Tim: We ended up running into a pretty significant group of issues when we pushed our latest milestone to production. We'll obviously need to audit what we're doing on the code side but this now seems pretty important to us.
Blocks: 570877
Tim, any idea when we'd be able to get this running? We really don't have another way to test our fix for the issues we saw during our last push and won't have high confidence in the code until it's tested.
Severity: normal → critical
Summary: [Can we] get a master/slave DB set up for support-stage-new[?] → Get a master/slave DB set up for support-stage-new
Not sure yet. AMO servers are falling over, have hard deadline to finish fixing by Thursday. Will look at this after that. Friday-ish?
(In reply to comment #3)
> Not sure yet. AMO servers are falling over, have hard deadline to finish fixing
> by Thursday. Will look at this after that. Friday-ish?

Friday-ish works, as long as we have some time frame.
Tim, it sounds like you're pretty insanely busy with AMO (bug 572518) at the moment, is there someone else who could help take this bug off your plate?
tm-stage01-master01 replicates the support_stage_new_mozilla_com database to tm-stage01-slave01. Is that what you're asking for in this ticket?

Here's the demonstration create table:
[root@tm-stage01-master01 11:30:59 ~]
:) mRoot support_stage_new_mozilla_com -e "create table zzz_timelesstest (a integer)"
[root@tm-stage01-slave01 11:34:06 ~]
:) mRoot support_stage_new_mozilla_com -e "show tables like '%zzz%'"
| zzz_timelesstest                                | 

Drop tables:
[root@tm-stage01-master01 11:35:03 ~]
:) mRoot support_stage_new_mozilla_com -e "drop table if exists zzz_timelesstest"
[root@tm-stage01-slave01 11:35:13 ~]
:) mRoot support_stage_new_mozilla_com -e "show tables like '%zzz%'"
 [[[no results]]]
In that case, is this set up as a slave database in the settings_local.py for support-stage-new?
settings_local.py just had the settings from mrapp-stage02 copied over, which lacked the slave config. I just added it to kitsune/settings_local.py and webroot/db/local.php.
And it seems to be working. Yay!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Now we can reproduce the bug we saw during the push. Yay!
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.