Last Comment Bug 571389 - [HTML5] <basefont> breaks out of <head> (on tdcanadatrust.com)
: [HTML5] <basefont> breaks out of <head> (on tdcanadatrust.com)
Status: VERIFIED FIXED
[3.7a5]
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: ---
Assigned To: Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26)
:
Mentors:
https://easyweb37w.tdcanadatrust.com/
Depends on:
Blocks: html5-parsing
  Show dependency treegraph
 
Reported: 2010-06-10 16:17 PDT by Anthony Hughes (:ashughes) [GFX][QA][Mentor]
Modified: 2010-09-15 15:59 PDT (History)
6 users (show)
hsivonen: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
final+


Attachments
Screenshot: The Good (41.89 KB, image/png)
2010-06-10 16:20 PDT, Anthony Hughes (:ashughes) [GFX][QA][Mentor]
no flags Details
Screenshot: The Bad (20.81 KB, image/png)
2010-06-10 16:21 PDT, Anthony Hughes (:ashughes) [GFX][QA][Mentor]
no flags Details
Screenshot: The Ugly (46.38 KB, image/png)
2010-06-10 16:22 PDT, Anthony Hughes (:ashughes) [GFX][QA][Mentor]
no flags Details
Source: Main Frame (2.45 KB, text/plain)
2010-06-10 20:17 PDT, Anthony Hughes (:ashughes) [GFX][QA][Mentor]
no flags Details
Source: Main Frame (1.83 KB, text/plain)
2010-06-10 20:18 PDT, Anthony Hughes (:ashughes) [GFX][QA][Mentor]
no flags Details
Source: Details Frame (28.78 KB, text/plain)
2010-06-10 20:19 PDT, Anthony Hughes (:ashughes) [GFX][QA][Mentor]
no flags Details
Make <basefont> and <bgsound> behave like <link> in the tree builder (45.39 KB, patch)
2010-06-11 08:18 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26)
jonas: review+
Details | Diff | Splinter Review

Description Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 16:17:50 PDT
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a5) Gecko/20100610 MozillaDeveloperPreview/3.7a5

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100607 Minefield/3.7a5pre

My banking site, tdcanadatrust.com, has a very bad user experience on trunk.  The main account page seems to work fine, but some pages lack CSS and some links produce Servlet Not Found error pages.  The site works fine on previous versions of Firefox, Safari, IE, and Opera.  I don't see any errors in Error Console or terminal.
Comment 1 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 16:20:37 PDT
Created attachment 450492 [details]
Screenshot: The Good
Comment 2 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 16:21:41 PDT
Created attachment 450493 [details]
Screenshot: The Bad
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 16:22:03 PDT
Created attachment 450494 [details]
Screenshot: The Ugly
Comment 4 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 16:37:54 PDT
Regression Range:

2010-05-03-03-mozilla-central
  |
  |-- regression caused somewhere in here
  |
2010-05-04-03-mozilla-central
Comment 5 Timothy Nikkel (:tnikkel) 2010-06-10 18:49:41 PDT
That range includes enabling the html5 by default. Does it work if you disable it by setting html5.enable to false in about:config?
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 19:27:11 PDT
(In reply to comment #5)
> That range includes enabling the html5 by default. Does it work if you disable
> it by setting html5.enable to false in about:config?

Yup, looks like HTML5 is causing the problem...
Comment 7 Boris Zbarsky [:bz] (TPAC) 2010-06-10 19:37:32 PDT
Can you attach the source of one of the pages involved here?  Or send it to Henri directly if it contains data you'd rather not make public to the world?
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 20:17:05 PDT
Created attachment 450566 [details]
Source: Main Frame
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 20:18:45 PDT
Created attachment 450567 [details]
Source: Main Frame
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 20:19:49 PDT
Created attachment 450569 [details]
Source: Details Frame
Comment 11 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-10 20:23:14 PDT
I've attached two source files:

Main Frame - the source code for the page
Details Frame - the source code for the frame containing my accounts details (this frame is loaded near the end of the Main Frame file)

Both of these make up a the page I use to view my accounts.

For security reasons, I've replaced my personal information in the source with ##########.
Comment 12 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-06-10 23:32:43 PDT
It looks like this is caused by <basefont> breaking out of <head>, which makes <base> get appended to <body> where <base> doesn't take effect.

Spec bug filed:
http://www.w3.org/Bugs/Public/show_bug.cgi?id=9910

(It's a no-brainer how to fix this, so I'm not implying that it's necessary to wait for a spec change to act.)
Comment 13 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-06-10 23:47:10 PDT
Note that the old parser as well as WebKit let <basefont> break out of <head>, but they compensate by hoisting <base> to <head>.
Comment 14 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-06-11 08:18:49 PDT
Created attachment 450661 [details] [diff] [review]
Make <basefont> and <bgsound> behave like <link> in the tree builder

Let's try to get this in beta. I chatted with Hixie; we don't need to wait for the spec.

I intend to write test cases for the html5lib suite, but I had other stuff to take care of today.
Comment 15 IU 2010-06-19 15:24:03 PDT
NOTE: This works with html5.enable=TRUE up to, and including the May 3 build.  It breaks starting with the May 4 build.  Thus, the culprit is not bug 373864, specifically, but one of the other bugs that also got checked in at the same time.
Comment 16 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-06-29 00:35:52 PDT
http://hg.mozilla.org/mozilla-central/rev/071e01b40032

I'll ask the html5lib maintainers if they are OK with me pushing tests for this before Hixie edits the spec.
Comment 17 IU 2010-06-29 12:30:55 PDT
Confirming fix.

http://hg.mozilla.org/mozilla-central/rev/0e0e2516f04e

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100629 Minefield/4.0b2pre ID:20100629040209
Comment 18 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2010-06-29 15:23:20 PDT
FWIW, if we actually ever wanted to implement <basefont>, it should be a container.  HTML4 contained incorrect reverse-engineering of how it worked.  See bug 3875 comment 47.
Comment 19 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-06-30 12:51:34 PDT
(In reply to comment #18)
> FWIW, if we actually ever wanted to implement <basefont>, it should be a
> container.  HTML4 contained incorrect reverse-engineering of how it worked. 
> See bug 3875 comment 47.

I've been assuming that actually supporting <basefont> will stay WONTFIX for Gecko and for the HTML5 spec.
Comment 20 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-06-30 15:08:56 PDT
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100630 Minefield/4.0b2pre

My tdcandatrust.com accounts page now looks good again.  I've not experienced any problems since this has landed.  Marking VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.