400 Bad Request - Invalid URI in request GE/m/ HTTP/1.1

RESOLVED INVALID

Status

()

Core
Networking: HTTP
P3
minor
RESOLVED INVALID
17 years ago
15 years ago

People

(Reporter: Jacob Steenhagen, Assigned: Gagan)

Tracking

({verifyme})

Trunk
x86
Windows 2000
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
I've recieved the bad request various times when clicking on links in bugzilla,
however have been unable to find any conistancy to it at all.  Clicking in the
location bar and hitting enter always seems to bring up the page correctly.  I
just got the error again, but this time it was when type "mail.yahoo.com" into
the location bar (every other time it was when clicking on links in bugzilla).
The error message in the summary came from Yahoo!, not bugzilla.

I know this is a far from perfect bug report, but I've been unable to get
specific reproduce steps as it seems to be very intermittant.  Perhaps it's
realated to cookies as it seems like every time I got it there was some
reference to cookies (don't know for sure as I didn't track it each time).
(Reporter)

Comment 1

17 years ago
Created attachment 17457 [details]
Exact HTML of error message from Yahoo!
(Reporter)

Comment 2

17 years ago
Created attachment 17466 [details]
Exaxt HTML given by Bugzilla
(Assignee)

Comment 3

17 years ago
morse: these attachments suggest that the cookie headers may not be ending on a
newline. Could you investigate/verify? thx. 
Assignee: gagan → morse

Comment 4

17 years ago
This is certainly not a cookie problem.  Cookie bustages can't cause the 
network traffic to be splattered over the display of the content, which is what 
happened here.  Not only was the linefeed missing on the cookie line, but the 
GET line has been chopped up, so there's no reason to suspect cookies.

There are many strange things going on here, such as the message from the two 
sites being almost identical, including the name and value of the cookie.  
Sounds like a problem that we were seeing a while ago, but I can't locate the 
bug report and that one was reprocible.

In any case, I can't even begin to investigate this since it is not reproducible 
(according to the reporter).  So I'm giving it back to netwerking, which is most 
probably where the cause it.
Assignee: morse → gagan
(Reporter)

Comment 5

17 years ago
I wish I could reproduce it with some sort of consistancy.  It just seems to
happen every now and then.  Mostly it happens when clicking around bugzilla.  I
don't recall seeing it before 10/17's build.  I really wish I could give more
information as I know how difficult it is to track down a problem that can't be
reproduced.

Downgrading severity as reloading the page as described above always seems to
make it work.
Severity: normal → minor
(Reporter)

Comment 6

17 years ago
OK, after try this on multiple machines, I've noticed that I don't see it at
home (WinME) or on my dialup PC at work (Win98).  Besides the OS differences,
the Win2K machine is also the only one to use the Proxy Server (a gauntlet
firewall).  I don't see these problems with IE.  I don't know if this has
anything to do with bug 45747, but I do know that the headers Mozilla is sending
are under scrutinaztion in that bug.

Comment 7

17 years ago
This is a much different problem... unrelated to bug 45747.  You say that the
bug is only showing up when connecting through the gauntlet proxy server.
Could it be then that this is a bug in the proxy server???  Do we have any
way of eliminating that possibility?
(Reporter)

Comment 8

17 years ago
I saw this problem many times this morning using Netcape Webmail with IE.  I do
find it strange that it mostly seems to happen to me on Netscape related sites.
(with the exception of the one time I saw it happen on Yahoo).  Being that I've
now seen this in both IE and Mozilla, I'm going to mark this bug as INVALID and
assume the problem is in the proxy server.

This may have to do with HTTP/1.1 as I only recently told IE to use HTTP/1.1
through proxy. Bug 60811 already covers this (which was split from bug 45747).
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 9

17 years ago
added keyword verifyme.
Keywords: verifyme

Updated

17 years ago
Blocks: 61691

Updated

15 years ago
QA Contact: tever → benc

Updated

15 years ago
Component: Networking → Networking: HTTP
QA Contact: benc → tever
You need to log in before you can comment on or make changes to this bug.