Timezone service broken on trunk due to extension manager changes

RESOLVED DUPLICATE of bug 563170

Status

Calendar
General
RESOLVED DUPLICATE of bug 563170
8 years ago
8 years ago

People

(Reporter: standard8, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
calTimezoneService is broken on trunk due to the recent extension manager changes. When starting up Thunderbird with Lightning installed I see:

JavaScript strict warning: file:///Users/moztest/comm/main/tb2/mozilla/dist/ShredderDebug.app/Contents/MacOS/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/moztest/comm/main/tb2/mozilla/dist/ShredderDebug.app/Contents/MacOS/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calTimezoneService.js, line 148: reference to undefined property Components.classes['@mozilla.org/extensions/manager;1']

It needs to be adapted for the new API, including the async changes, see here for more details:

http://www.oxymoronical.com/blog/2010/03/How-were-breaking-some-extensions-in-the-near-future
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 563170
You need to log in before you can comment on or make changes to this bug.