Closed Bug 571855 Opened 10 years ago Closed 10 years ago

Install VNC on SeaMonkey Windows slaves

Categories

(SeaMonkey :: Release Engineering, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kairo, Assigned: kairo)

References

Details

I've so far punted on installing VNC on the Windows slaves, because 
https://wiki.mozilla.org/ReferencePlatforms/Win32#Install_RealVNC referred to a MoCo-internal repository I couldn't access, and because I'm accessing the machines via RDP usually anyhow.

Bug 558604 seems to imply that exactly that is the cause for some test failures now, so I'm looking into this again

First, I got vnc-4_1_3-x86_win32.exe from http://www.realvnc.com/products/free/4.1/download.html - I'll post the other steps once I got success on one machine.
Blocks: 558601
(using xxxxx@xxxxx.xxx for the name of my own machine where I have stored the file temporarily)

cd /d/dist/
scp xxxxx@xxxxx.xxx:temp/tools/net/vnc-4_1_3-x86_win32.exe .
vnc-4_1_3-x86_win32.exe
 * Click through the installer accepting all the defaults
 * When the setup window pops up set a password (default build machine password)
   and turn off the Java viewer
 * Add a firewall exception
   - Start Menu -> Control Panel -> Windows Firewall
   - Exceptions -> Add Port -> TCP/5900 
rm vnc-4_1_3-x86_win32.exe

cn-sea-qm-win2k3-01 is done.
In theory, all the machines should be done, but bug 571857 prevents us from any testing right now.
Depends on: 571857
VNC has been installed on all machines and they are online in the build pool again, let's see how this works out.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I seem to remember reading somewhere to be careful when making Remote Desktop connections to Windows slaves, because you could accidentally change the resolution and/or colour depth, which would make some tests fail. I take it this is now incidental, since we should not be using Remote Desktop any more.
(In reply to comment #4)
> I seem to remember reading somewhere to be careful when making Remote Desktop
> connections to Windows slaves, because you could accidentally change the
> resolution and/or colour depth, which would make some tests fail. I take it
> this is now incidental, since we should not be using Remote Desktop any more.

Right. With RDP, I always connected with the same settings, I have been careful about that. Unfortunately, using VNC now, any remote operations on those machines is sluggish, so I will refrain from that as much as possible.
Duplicate of this bug: 558604
Duplicate of this bug: 558601
No longer blocks: 558604
No longer blocks: 558601
You need to log in before you can comment on or make changes to this bug.