switching from in-browser to full screen causes the audio to skip

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
--
major
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: blizzard, Unassigned)

Tracking

Trunk
mozilla11
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: fixed by bug 470628, URL)

(Reporter)

Description

8 years ago
Right now when you right click to go to full screen you end up with audio that skips.  Other implementations don't do this and since we're going to production on youtube.com and other sites we need to get this to be flawless.
(Reporter)

Updated

8 years ago
Blocks: 569993

Updated

7 years ago
blocking2.0: --- → ?
I don't think we can block on this. It depends on big changes to the way we do fullscreen.
blocking2.0: ? → -
(Reporter)

Updated

7 years ago
Blocks: 631042
No longer blocks: 569993

Updated

7 years ago
Duplicate of this bug: 571432
This still happens. Is anyone planing on working on this?
Bug 470628 makes the context menu use the DOM full-screen API instead of mozLoadFrom.
Depends on: 470628
The same skips happen when using the full-screen API
Over here Firefox stops painting for about five seconds (this is quite bad), but the sound keeps going just fine.
(In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> The same skips happen when using the full-screen API

That's a different problem then. Make sure you're using a build with DOM full-screen enabled (the patch in bug 470628 will fall back to the old method when DOM fullscreen is not enabled).

On trunk the problem is that we create a new media element and have to spin up its decoder and seek to the right place. There's an inherent delay there of course.

With bug 470628 fixed, we don't do that, the same element is used at all times. We should be able to keep audio going during that time, as Dao observed. A five-second painting delay sounds bad but is a different bug.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #7)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> > The same skips happen when using the full-screen API
> 
> That's a different problem then. Make sure you're using a build with DOM
> full-screen enabled (the patch in bug 470628 will fall back to the old
> method when DOM fullscreen is not enabled).

Indeed. It is working now. Nevermind then.

Updated

6 years ago
Whiteboard: fixed by bug 470628
Target Milestone: --- → mozilla11
Component: Audio/Video → Audio/Video: Playback
This has long since been fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.