descenders clipped if "always use my colors"=true

VERIFIED FIXED in mozilla0.9

Status

()

Core
Layout
P3
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: BenB, Assigned: Marc Attinasi)

Tracking

Trunk
mozilla0.9
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Reproduce:
1. Set "Always use my colors" pref to true
2. Open testcase

Actual result:
The lower part of the first "g"s is cutted - overlaid by the link on the next
line. Everything is OK, if the next line is not a link, or if the "Always use my
colors" pref is sat to false.

See screenshots.
(Reporter)

Comment 1

18 years ago
Created attachment 17508 [details]
Reduced testcase
(Reporter)

Comment 2

18 years ago
Created attachment 17509 [details]
Screenshot showing the bug (via the testcase attached)
(Reporter)

Comment 3

18 years ago
s/screenshots/screenshot/
Keywords: mozilla0.9
(Reporter)

Comment 4

18 years ago
I guess,  you |inherit| the background color instead of setting it to transparent.
(Assignee)

Updated

18 years ago
Blocks: 57234
(Assignee)

Comment 5

18 years ago
Accepting, assigning milestone for attention post-RTM
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9
clarifying summary.
Summary: Lower part of glyphs cutted, if "always use my fonts"=true → descenders clipped if "always use my fonts"=true
(Assignee)

Comment 7

18 years ago
Correcting summary: it is the color pref that is doing this, not the font pref.
Summary: descenders clipped if "always use my fonts"=true → descenders clipped if "always use my colors"=true
(Assignee)

Comment 8

18 years ago
*** Bug 58195 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

18 years ago
Fix checked into trunk (see bug 57234).
(nsPResShell.cpp, html.css)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
Marking verified in the March 5 build.
Status: RESOLVED → VERIFIED
Blocks: 78106
No longer blocks: 78106
You need to log in before you can comment on or make changes to this bug.