Add a download indicator to Dock item under Mac OS.

RESOLVED DUPLICATE of bug 548763

Status

()

Firefox
Shell Integration
--
enhancement
RESOLVED DUPLICATE of bug 548763
8 years ago
8 years ago

People

(Reporter: David Hsu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a6pre) Gecko/20100617 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a6pre) Gecko/20100617 Minefield/3.7a6pre

With AOM integrated into tab, I believe that download manager will soon be dealt with too. But apart from that, users should be able to see their download progress clearly and without the need to be in Firefox to be able to see them.

I can see now Firefox has made good use of Windows 7's superbar:
http://cl.ly/1924e220d2efbc4ce4a3

So for Mac OS, can you add an indicator to Dock icon? Google itself has a pretty nicely done implementation for Chrome:
http://cl.ly/205139f40c43b0e2152e

Make sense, huh? ;)

Reproducible: Always

Steps to Reproduce:
1. Download any file.
Actual Results:  
If I don't leave the download manager open or till downloads finish, I won't be able to easily see what their progress are.

Expected Results:  
Ask Chrome!

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548763
You need to log in before you can comment on or make changes to this bug.