Closed Bug 572972 Opened 10 years ago Closed 8 years ago

new geolocation popup: show geo icon when geolocation is active, allow managing permission prefs

Categories

(Firefox :: Search, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 630614

People

(Reporter: Gavin, Assigned: Gavin)

References

Details

(Whiteboard: popupnotification)

When navigating to a page that makes geoLocation calls, we should show the geolocation icon (added by patch in bug 398776), and have it trigger a separate popup that allows undoing "allow always" decisions. This depends on bug 572967's support for pre-"dismissed" notifications.
Assignee: nobody → gavin.sharp
Depends on: 572967
Summary: new geolocation popup: show "geo" icon when geolocation is active, allow managing permission prefs → new geolocation popup: show geo icon when geolocation is active, allow managing permission prefs
Whiteboard: popupnotification
Duping to bug 630614 because that's where discussion about fixing this issue has been taking place.
Status: NEW → RESOLVED
Closed: 8 years ago
Component: General → Search
Resolution: --- → DUPLICATE
Duplicate of bug: 630614
You need to log in before you can comment on or make changes to this bug.