Localize mozilla.org home page

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: davidwboswell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments)

(Reporter)

Description

8 years ago
This bug can be used to coordinate localization of the Get home page on
mozilla.org.  If localized text or HTML is attached, I can check this in to the
site (and we can work toward getting commit access to various localizers).

Note that the the home page includes a couple of feeds in English that can be replaced by more appropriate locale-specific feeds if available.

Comment 1

8 years ago
http://pastebin.mozilla.org/738800

english and croatian translation side by side
(Reporter)

Comment 2

8 years ago
As mentioned in the initial comment, in addition to localizing the static text we'll need to sort out what to do about the feeds getting pulled into the page before we go live with any localized home page versions.  For the Croatian version, feel free to post links to any relevant feeds in this bug.

Comment 3

8 years ago
fur locale  (home) [expiration one month]
http://pastebin.com/REedjU4X

Comment 4

8 years ago
the same  home.fur.html   in mozilla.org  
fur friulian home localization 
http://pastebin.mozilla.org/762908

Comment 5

8 years ago
more polite ?  http://pastebin.mozilla.org/762926
from trunk version 6881 index.fur.html
(Reporter)

Comment 6

8 years ago
Great, I'm excited to see a translation of the home page.  I apologize for leaving this out of the initial bug report but the home page text will be changing somewhat when we go live with the new home page design.  You can see an example of it at

http://davidwboswell.wordpress.com/2010/08/06/refreshing-the-mozilla-org-home-page-part-2/

I'd suggest holding off on adding any localizations of the home page until the new design is live in a few weeks.

Comment 7

8 years ago
Created attachment 501353 [details]
[fr] French translation of Home page

[fr] French translation of Home page. Reviewed by Jean-Bernard (Goofy) Marcon.
(Reporter)

Comment 8

8 years ago
Re the French attachment 501353 [details] from comment #7, I'm seeing strange characters when I'm opening it.

For this page, there is some content that updates on a regular basis -- the news feed and the items in the right sidebar that are updated weekly.  Would it be better to try to keep the localized pages updated regularly or create localized pages that are more permanent (for example we could create items in the right sidebar that are stable and not tied to a specific time frame)?

Comment 9

8 years ago
As Bugzilla doesn't specify the page encoding when displaying attachment details, the browser picks its default one, that is ISO8859-1, at least for en-US and fr, though the attachment is UTF8 encoded, hence the weird characters.
I sent you the files by email.

More permanent localized pages would be better, especially as we have currently no easy way (Verbatim or l10n SVN repository access to these pages) to update them.
(Reporter)

Comment 10

8 years ago
OK, I can work on a permanent alternate version of the page that can then be localized.
(Reporter)

Comment 11

8 years ago
I added the Croatian version of the home page and it is missing the main introductory content:

http://www.mozilla.org/index.hr.html

I added the French version and it's not showing up at all.  Must be an HTML or PHP error -- I haven't had a chance to look into it yet.

http://www.mozilla.org/index.fr.html

Comment 12

8 years ago
Created attachment 503171 [details]
croatian update

as advised translated the english inside script
(Reporter)

Comment 13

8 years ago
The updated Croatian localization has been checked in.

http://viewvc.svn.mozilla.org/vc?view=revision&revision=80640

Comment 14

8 years ago
Created attachment 504275 [details]
Albanian (sq) translation of trunk/index.html
(Reporter)

Updated

8 years ago
Attachment #504275 - Attachment mime type: text/html → text/plain;charset=utf-8
(Reporter)

Comment 15

8 years ago
Albanian version of home page posted at

http://www.mozilla.org/index.sq.html
Created attachment 511154 [details]
German (de) translation of index.html

I’m attaching the German (de) version of the index.html page of mozilla.org.
(Reporter)

Updated

8 years ago
Attachment #511154 - Attachment mime type: text/plain → text/plain;charset=utf-8
(Reporter)

Comment 17

8 years ago
The German localization of the home page is now up at

http://www.mozilla.org/index.de.html
The Brazilian Portuguese - pt_BR  localization of home page

http://pastebin.mozilla.org/1233862
(Reporter)

Comment 19

7 years ago
I added Rodrigo's Portuguese localization on the home page to the staging site at

http://www-stage.mozilla.org/index.pt.html

There seem to be some encoding issues -- maybe something got garbled when I copied this over from pastebin?  I've had good look with text attached to bugs where the encoding can be set.  I'll try that and see if it helps.
(Reporter)

Comment 20

7 years ago
Created attachment 535368 [details]
Portuguese localization
(Reporter)

Comment 21

7 years ago
That didn't seem to help -- Rodrigo, could you try adding the original text you had added to pastebin to this bug as an attachment?  Thanks.
Ops, I will convert all special characters to HTML code.
File updated http://pastebin.mozilla.org/1238333

I've changed all accentuated words using the respective HTML code.

More one correction, the Brazilian Portuguese is pt_BR not only pt like you added to the localized file.
(Reporter)

Comment 24

7 years ago
Rodrigo, thanks for reposting.  That seems to have fixed all the issues I was seeing.  Check out the page on stage at

http://www-stage.mozilla.org/index.pt-BR.html

Note that based on your feedback I changed the file name from index.pt.html to index.pt-BR.html (and we'll be moving to the more standard l10n URL structure on www.mozilla.org soon).

If this looks good, I'll move it to the live site.
Only a small correction.

Replace the word "Você" by "Você" in the html code bellow

<div id="sidebar">
<div class="promo"> <a href="/join?WT.ac=join_h_a"><img
src="/images/promos/join_promo_a.png"
alt="Você pode ajudar! Junte-se à Mozilla." height="150" width="245"></a></div>
<ul class="more">

Doing it, the text is ok to be finally published.

Ahh, the block "In the news" is translatable?

Thanks!
Replace the word "você" by "voc&ecirc;" in the text bellow too

<li>
<h3>Reinvente Notícias Online</h3>
<p>Nos mostre como você pode contar uma história em uma nova


Sorry by so many update in that bug, nex time I will do in a better way. That's my first time translating content directly inside HTMl
(Reporter)

Comment 27

7 years ago
OK, I made the changes from comment #25 and #26 on stage.  Please confirm that things looks correct there (it might be about 15 minutes before the change shows up).

> Ahh, the block "In the news" is translatable?

Right now there are parts of www.mozilla.org that can't be localized since we don't have a full localization system in place (this covers the header and footer as well as feeds such as the In The News block).  We should be able to fix this soon, but for now this is as much as we can do.
Now everything is ok! Thanks and sorry by so many updates here.

I will start to translate the other pages using the correct configs :-)

I will get the next stable pages from the whish list
https://wiki.mozilla.org/Mozilla.org/Localization_wishlist
(Reporter)

Comment 29

7 years ago
The pt-BR home page localization is now live.  Thanks Rodrigo!

http://www.mozilla.org/index.pt-BR.html
Created attachment 538429 [details]
Fixes to the pt-BR translation.

This is the pt-BR translation of the home page @ r89739
I fixed a few typos, translated some missing strings and restored the original indentation.
Attachment #538429 - Attachment mime type: text/plain → text/html;charset=utf-8
Attachment #538429 - Attachment mime type: text/html;charset=utf-8 → text/plain;charset=utf-8
(Reporter)

Comment 31

7 years ago
Thanks for the fixes Reuben.  I checked this in to staging at

http://www-stage.mozilla.org/index.pt-BR.html

Reuben and Rodrigo, can you confirm that this looks good and then I'll move it to production.  Thanks.
Looks good to me David.
(Reporter)

Comment 33

7 years ago
Great, Reuben.  Rodrigo, let us know when you've had a chance to look at this.
The page is pretty good!! I will start to translate the next files ;-)
(Reporter)

Comment 35

7 years ago
Rodrigo, great.  I just moved these changes to the pt-BR home page to production in r90481.
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Updated

6 years ago
Component: General → L10N
(Reporter)

Comment 36

6 years ago
Note that this bug is about the old mozilla.org home page before the .org and .com merge so this may now be a dupe of a bug for localizing the new home page.

Comment 37

6 years ago
Closing per David's comment above.  If needed, we will open a new bug to localize the new home page.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.