Last Comment Bug 573105 - Can't report international (рф) domain names
: Can't report international (рф) domain names
Status: RESOLVED FIXED
[upstream]
:
Product: Input
Classification: Server Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal
: 4.x
Assigned To: Nobody; OK to take it and work on it
: input-deleted
:
Mentors:
http://www.правительство.рф/
: 662147 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 12:34 PDT by Kevin Brosnan
Modified: 2013-03-28 06:48 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot of submitting a рф domain (314.69 KB, image/png)
2010-06-18 12:34 PDT, Kevin Brosnan
no flags Details

Description Kevin Brosnan 2010-06-18 12:34:29 PDT
Created attachment 452318 [details]
Screenshot of submitting a рф domain

http://www.правительство.рф/ is a valid domain. Input throws an error when I try and submit it.
Comment 1 Kevin Brosnan 2010-06-18 12:40:51 PDT
Does not accept the punycode version of the address either http://www.xn--80aealotwbjpid2k.xn--p1ai/
Comment 2 Fred Wenzel [:wenzel] 2010-06-18 12:42:19 PDT
Sounds like a Django bug.
Comment 3 Fred Wenzel [:wenzel] 2010-06-19 05:07:41 PDT
Yup, while Django's URLField now supports IDNs, it does not support the ones whose TLDs are longer than "regular". That's bug http://code.djangoproject.com/ticket/12988 over on the Django bugtracker.
Comment 4 Fred Wenzel [:wenzel] 2011-06-05 18:57:30 PDT
*** Bug 662147 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Brosnan [:kbrosnan] 2011-06-05 21:47:46 PDT
Looks like the fix has been provided by upstream. What would upgrading involve?
Comment 6 Dave Dash [:davedash, :dd] (assign all bugs to mbrandt) 2011-06-06 09:03:26 PDT
(In reply to comment #5)
> cc: kbrosnan@mozilla.comLooks like the fix has been provided by upstream.
> What would upgrading involve?

Where upstream?  We're using 1.3 now.  Is it still happening?
Comment 7 Kevin Brosnan [:kbrosnan] 2011-06-06 10:16:25 PDT
There was a bug filed for the live version of Input on yesterday.
Comment 8 Fred Wenzel [:wenzel] 2011-06-06 11:41:43 PDT
I still see it happening on my dev instance. Though the link in comment 3 seems to indicate it's fixed. Uuuhm?
Comment 9 Aakash Desai [:aakashd] 2011-10-05 09:53:54 PDT
I can confirm this is still not working.
Comment 10 Will Kahn-Greene [:willkg] 2013-03-28 06:48:17 PDT
We just pushed out a rewrite of Input last night which uses Django 1.4.5. I tested this in our stage environment and it works now.

Note You need to log in before you can comment on or make changes to this bug.