Closed Bug 573127 Opened 10 years ago Closed 10 years ago

"ASSERTION: Why did this not get handled while processing mRestyleRoots?" with mathvariant

Categories

(Core :: CSS Parsing and Computation, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla2.0b1

People

(Reporter: jruderman, Assigned: bzbarsky)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(2 files)

Attached file testcase
There are lots of ways to trigger this assertion.  I have semi-reduced testcases for lots of them.

###!!! ASSERTION: Why did this not get handled while processing mRestyleRoots?: '!element->HasFlag(collector->tracker->RootBit()) || (element->GetFlattenedTreeParent() && !element->GetFlattenedTreeParent()->GetPrimaryFrame()) || (aData.mChangeHint & nsChangeHint_ReconstructFrame)', file /builds/slave/mozilla-central-macosx-debug/build/layout/base/RestyleTracker.cpp, line 114
Certainly mine.
Blocks: 479655
Yeah, ok.  The assert needs a small adjustment to make it match reality.
Attached patch Like soSplinter Review
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #452414 - Flags: review?(dbaron)
Comment on attachment 452414 [details] [diff] [review]
Like so

r=dbaron, though it's getting to be a pretty confusing assertion
Attachment #452414 - Flags: review?(dbaron) → review+
Yeah, the problem is it's trying to catch cases when flags would be removed "incorrectly", and those cases are complicated.  :(
Pushed:

  http://hg.mozilla.org/mozilla-central/rev/13a9aecb404f
  http://hg.mozilla.org/mozilla-central/rev/fe16c033cfa7
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a6
You need to log in before you can comment on or make changes to this bug.