Closed Bug 573259 Opened 10 years ago Closed 5 years ago

Intermittent browser_relative.js | Timed out followed by unexpected tabs and other errors

Categories

(Toolkit :: Add-ons Manager, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED WORKSFORME
mozilla14

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: comment 247 has info)

Attachments

(3 files)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276973752.1276975073.15976.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitest-other on 2010/06/19 11:55:52
s: talos-r3-leopard-016

TEST-START | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Found 1 unexpected tab(s) at the end of test run
TEST-INFO | checking window state
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XPCNativeWrapper [object Window]]) about:blank docshell visible: true
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | already focused
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XPCNativeWrapper [object Window]]) about:blank docshell visible: true
TEST-START | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_signed_multiple.js
*** LOG addons.xpi: Download started for http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/signed.xpi to file /Users/cltbld/Library/Caches/TemporaryItems/tmp-edb.xpi
*** LOG addons.xpi: Download of http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/signed.xpi completed.
*** LOG addons.xpi: Verifying XPI signature
*** LOG addons.xpi: Download started for http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/signed2.xpi to file /Users/cltbld/Library/Caches/TemporaryItems/tmp-yxb.xpi
*** LOG addons.xpi: Download of http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/signed2.xpi completed.
*** LOG addons.xpi: Verifying XPI signature
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_signed_multiple.js | Console message: LOG addons.xpi: Download started for http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/signed.xpi to file /Users/cltbld/Library/Caches/TemporaryItems/tmp-edb.xpi
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_signed_multiple.js | Console message: LOG addons.xpi: Download of http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/signed.xpi completed.
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_signed_multiple.js | Console message: LOG addons.xpi: Verifying XPI signature
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_signed_multiple.js | Console message: LOG addons.xpi: Download started for http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/signed2.xpi to file /Users/cltbld/Library/Caches/TemporaryItems/tmp-yxb.xpi
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_signed_multiple.js | Console message: LOG addons.xpi: Download of http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/signed2.xpi completed.
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_signed_multiple.js | Console message: LOG addons.xpi: Verifying XPI signature
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Should only be 1 item listed in the confirmation dialog - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Should have seen the name - Got Signed XPI Test, expected XPI Test
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Should have listed the correct url for the item - Got http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/signed.xpi, expected http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/unsigned.xpi
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Should have listed the correct icon for the item - Got , expected http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/icon.png
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Should have listed the item as unsigned - Got true, expected false
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1277291688.1277293264.10373.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/06/23 04:14:48
s: talos-r3-snow-005

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Found an unexpected tab at the end of test run: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22Unsigned%20XPI%22%3A%7B%22URL%22%3A%22unsigned.xpi%22%2C%22IconURL%22%3A%22icon.png%22%7D%7D
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1277288141.1277289134.19560.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitest-other on 2010/06/23 03:15:41
s: talos-r3-leopard-017

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Found an unexpected tab at the end of test run: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22Unsigned%20XPI%22%3A%7B%22URL%22%3A%22unsigned.xpi%22%2C%22IconURL%22%3A%22icon.png%22%7D%7D
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1278316001.1278317007.32537.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/07/05 00:46:41

s: talos-r3-snow-005
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Found an unexpected tab at the end of test run: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22Unsigned%20XPI%22%3A%7B%22URL%22%3A%22unsigned.xpi%22%2C%22IconURL%22%3A%22icon.png%22%7D%7D
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1278592161.1278592800.32680.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitest-other on 2010/07/08 05:29:21

s: talos-r3-leopard-007
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Found an unexpected tab at the end of test run: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22Unsigned%20XPI%22%3A%7B%22URL%22%3A%22unsigned.xpi%22%2C%22IconURL%22%3A%22icon.png%22%7D%7D
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1278645941.1278647488.16097.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/07/08 20:25:41

s: talos-r3-leopard-032
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Found an unexpected tab at the end of test run: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22Unsigned%20XPI%22%3A%7B%22URL%22%3A%22unsigned.xpi%22%2C%22IconURL%22%3A%22icon.png%22%7D%7D
This times out A LOT.  Is anyone working on this?
Mossop, does this test (and other tests which use installtrigger.html) correctly handle the case where InstallTrigger.install throws?  Reading the code, I think that basically such an exception would result in a test timeout.  Is that right?
(In reply to comment #124)
> Mossop, does this test (and other tests which use installtrigger.html)
> correctly handle the case where InstallTrigger.install throws?  Reading the
> code, I think that basically such an exception would result in a test timeout. 
> Is that right?

I guess this one doesn't. The tests that expect and exception handle it correctly of course, but maybe that is what is going on here. Would be surprising.
So, is it possible that this is actually uncovering a problem in the code?
(In reply to comment #126)
> So, is it possible that this is actually uncovering a problem in the code?

Possibly yes. I am making a patch that we can land to verify whether it is throwing an exception or not.
Great!  Thanks for following up on this so quickly!
(In reply to comment #128)
> Great!  Thanks for following up on this so quickly!

Thanks for coming up with at least a theory, I've been racking my brains over what might be causing this to fail.

This patch is pretty simple, it re-throws any exception from InstallTrigger.install meaning it will be uncaught by the webpage and so show up in the log as a TEST-INFO line.

This probably won't give us a direct answer to what the problem is here but it'll at least indicate if we are looking in the right direction.
Attachment #459261 - Flags: review?(ehsan)
Comment on attachment 459261 [details] [diff] [review]
log any exceptions from InstallTrigger.install
[Checked in: Comment 133]

Looks sane.
Attachment #459261 - Flags: review?(ehsan) → review+
This last orange included the additional debugging and it shows no exception getting thrown so it looks like that isn't the problem.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1279803447.1279804704.16873.gz

Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitest-other on 2010/07/22 05:57:27
s: talos-r3-leopard-017
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Found a tab after previous test timed out: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22Unsigned%20XPI%22%3A%7B%22URL%22%3A%22unsigned.xpi%22%2C%22IconURL%22%3A%22icon.png%22%7D%7D
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1280247291.1280248854.26279.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2010/07/27 09:14:51
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281287328.1281288027.6860.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitest-other on 2010/08/08 10:08:48

s: talos-r3-leopard-007
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Found a tab after previous test timed out: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22Unsigned%20XPI%22%3A%7B%22URL%22%3A%22unsigned.xpi%22%2C%22IconURL%22%3A%22icon.png%22%7D%7D
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1281270285.1281271216.26677.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey opt test mochitest-other on 2010/08/08 05:24:45

s: talos-r3-snow-024
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_relative.js | Found a tab after previous test timed out: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22Unsigned%20XPI%22%3A%7B%22URL%22%3A%22unsigned.xpi%22%2C%22IconURL%22%3A%22icon.png%22%7D%7D
It's possible that this will have been fixed by bug 550936. I guess if we see no more reports for a week or so then we can assume that is the case.
I believe I know the cause of this, I'm just not sure how to fix it. I think the browser still believes it to be offline (the previous test is browser_offline.js) and so the load of the page displays the offline notice. I don't know why the offline switch seems to be happening asynchronously or how to know when it is complete.