Closed Bug 573287 Opened 11 years ago Closed 11 years ago

cannot start firefox after installing 3 add-ons, (in any order), killing firefox (pkill firefox).

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jd1008, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100403 Fedora/3.6.3-4.fc13 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100403 Fedora/3.6.3-4.fc13 Firefox/3.6.3

This is the wierdest bug I have ever seen in firefox.
I installed adblockplus. and restarted firefox.
So far so good - no problems.
I killed it (deliberately) via pkill firefox.
I started firerfox again (from desktop icon),
and I was able to restore previous session.
----------
I installed a second add-on (tubestop), and restarted firefox for the add-on to take effect.
Again, do far so good.
I killed firefox (pkill firefox).
I started firefox (from desktop icon),
and it started and I was able to restore previous session.
-----------------
I installed a third add-on (video downloadhelper), and restarted forefox for the add-on to take effect.
I pkill'ed firefox.
I tried to re-start firefox (from desktop icon),
and now it will not restart at all.

So, I did the following:
I wanted to see if this is caused by the fact that it is a fedora rpm package from which it got installed, or is it generic in the browser.
I downloaded the 32 bit binary from the mozilla site and installed
it into a different directory, and I created a special launcher for it on the dektop.

I was able to start it up and restore my previous session. No problem.

So I pkilled it again, and tried to start it (the mozilla.org version).
No go!! It will not start.

No the wierdest part:

I started firefox from the original icon (which starts /usr/bin/firefox).
It starts up and I am able to restart my previous session.

However, I cannot restart it after a pkill.
I have to ping-pong between the rpm installed version and the mozila.org dowloaded version in order to restore my session, after each pkill.

Often, I reboot the system after updates. I expect that firefox should
always start up and restore my sessions.

One more note, I tried to install the 3 add-on in different order.
Once I get to 3 add-ons, the problem re-appears.


Reproducible: Always
I just wanted to say sarry for the typos. I'm not the best typist :)

> Again, do far so good.
I meant
  Again, so far so good.

> No the wierdest part:
I meant
  Now the wierdest part:

Cheers,

JD
With only one or two add-ons, I can pkill and restart firefox 
indefinitely. But not with 3 add-ons.
Is anyone experiencing this issue?
The problem has disappeared all on it's own.
Same firefox, same add-ons, but new (automatic) updates came in for
other packages. Now the problem has completely disappeared.
Please close.
Jd, You can close your own bugs by setting status to resolved. And in this case, resolution to WORKSFORME
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.