Closed Bug 573294 Opened 12 years ago Closed 12 years ago

tasks sorted by "due" or "due in" sort tasks with no due date first

Categories

(Calendar :: Tasks, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 377041

People

(Reporter: greg.johnson, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-AU; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: 1.0b2

this puts the important tasks at the bottom of any list - not helpful!
(adding priority is not a solution, that attribute is a different aspect/domain)
eg

Title             Due
Task 4
Task 5
Task 1          10 June 2010
Task 2          20 June 2010
Task 3          30 June 2010

Reproducible: Always

Steps to Reproduce:
1. Add some tasks with no due by date
2. Add some task with due by date
3. Observer order of sorting in the task list
Actual Results:  
Title             Due
Task 4
Task 5
Task 1          10 June 2010
Task 2          20 June 2010
Task 3          30 June 2010

Expected Results:  
Title             Due
Task 1          10 June 2010
Task 2          20 June 2010
Task 3          30 June 2010
Task 4
Task 5

sorted tasks with due dates ahead of tasks without due dates
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377041
You need to log in before you can comment on or make changes to this bug.