Last Comment Bug 573387 - For SVG overflow='auto' should work like overflow='visible'
: For SVG overflow='auto' should work like overflow='visible'
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Robert Longson
:
:
Mentors:
: 622686 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-20 13:32 PDT by Robert Longson
Modified: 2011-01-03 14:20 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wanted


Attachments
patch with reftests (9.83 KB, patch)
2010-06-20 13:35 PDT, Robert Longson
no flags Details | Diff | Splinter Review

Comment 1 Robert Longson 2010-06-20 13:35:04 PDT
Created attachment 452600 [details] [diff] [review]
patch with reftests
Comment 2 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2010-06-21 00:01:58 PDT
Do we already have tests for svg, symbol, pattern and foreignObject? If not, can you rename the test to something like 'overflow-01.svg' and test each of those in its own little section of the screen?
Comment 3 David Baron :dbaron: ⌚️UTC-7 2010-06-30 18:20:33 PDT
I think this is a bad idea, since it gets along really badly with the overflow-x/overflow-y split.
Comment 4 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2010-07-06 17:57:28 PDT
David sent an email about this to www-svg:

http://lists.w3.org/Archives/Public/www-svg/2010Jul/0000.html
Comment 5 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2010-07-17 14:05:43 PDT
roc, does comment 3 change your mind on this?
Comment 6 Robert O'Callahan (:roc) (email my personal email if necessary) 2010-07-18 17:24:53 PDT
David's perfectly right. We should treat 'auto' as 'hidden'.
Comment 7 Robert Longson 2010-07-19 01:06:28 PDT
OK then.
Comment 8 Robert Longson 2011-01-03 14:12:37 PST
*** Bug 622686 has been marked as a duplicate of this bug. ***
Comment 9 Cameron McCormack (:heycam) 2011-01-03 14:20:22 PST
Goodness, my Bugzilla search-fu for existing bugs is weak. :-)

I'm sad to say that David's mail never got a reply, nor did it become a tracked issue.  I will bring it up again.

Note You need to log in before you can comment on or make changes to this bug.